[FIXED] When will they fix DX12?

UPDATE: Fixed it. Read more here for solution…

This is probably the 10000th post about DX12, but I used to play the game on DX12. Since the last 2 updates, the game absolutely cannot run on DX12 or it will throw the LowLevelFatalError exception. DX11 is so bad that I simply do not have the desire to play the game anymore since the game won’t run in DX12.

Something that’s probably worth noting is that when the game tries to load in DX12 mode, before the exception pops up, it will try to kill my CPU by running all 20 threads at max core clock causing huge spike in temperature for a few seconds before throwing the exception. Perhaps it’s doing some crazy fast loading and then failed? I don’t know.

Intel i9-7900X
Nvidia GTX 1080
32GB 3200MHz RAM
Windows 10 Pro 64-bit Build 1909

Game is on main SSD, same as Windows.

Error details:

LowLevelFatalError exception

There are minidumps available but I won’t upload it here since it seems to have some personally identifiable information in it. I am not sure. IF the developers requests for them and can tell me there’s nothing sensitive data in it, I will post it here.

yeah it happens every time for me

I’ve been playing on DX12 for several months now (I forget when I switched, but it was a dozen updates ago maybe?), and it’s not crashing for me. I mean, if I quit straight to desktop out of a fight, the game will sometimes hang when closing, but if I exit to the main menu, sit for a sec, and then quit, it’s fine (it’s not hanging in the middle of gameplay though).

It’s possible for it to run fine on DX12, but the number of variables involved in divining why some players computers experience this (or microstuttering, or any other random thing) and others’ don’t is beyond my ken (though I’m down to try to identify it if you’ve got an idea).

There was another very recent thread about DX12 not running properly:

The ‘fix’ there is odd, to say the least. @TokyoZero, are you on Epic or Steam there?

I actually tried that yesterday. No dice. Moved from HDD to main SSD, doesn’t work. Game was initially on another HDD, worked nicely with DX12 since I started playing. After one update, can’t pinpoint exactly when, the game suddenly stopped working in DX12 mode.

How do I nuke the “cache folder” or something that was mentioned in that thread? I looked around the Borderlands 3 folder in “Documents/My Games” but couldn’t find it there. Is it in %APPDATA% or %LOCALAPPDATA%? I haven’t tried to check there’s any Borderlands 3 folder there.

I also tried removing the config file, but it doesn’t fix anything. The game needs to be restarted in order for DX12 to be applied, that’s something OP in the thread you linked did not notice. That’s why they said they have to remove the config file every time they restart the game. Each time you clear the config, obviously the game will run because it resets back to the default setting, which is DX11.

@Adabiviak: I wish I could tell you what’s different or wrong. I’ve been running the game in DX12 mode since I started playing since a few months ago. But let me try listing what has happened since then:

  • Started playing: DX12 mode on immediately (I always configure my game completely before I start playing)
  • Survived many patches, game still ran fine even until the second latest DLC ( Bounty Of Blood)
  • Reformat to Windows 10 Pro

—> At this point game starts to break in DX12 mode, not sure before rebuilding or after rebuilding <—

  • Rebuilt my PC (from fully custom watercooled to fully aircooled, if that matters)
  • Downgraded GPU from GTX 1080 Ti to 1080 non-Ti (sadface but curse ZOTAC for refusing to sell the VRM heatsink which costs them nothing to make)

I had DX12 issues right off the bat, so played DX11 for a while, and then I heard on the forums that it was working, and it’s been good on DX12 since.

I’m on 10 Pro, version 1903, though I don’t think this’ll be the issue. I mean, I could suddenly have it stop working out of the blue too, but the game at its current version/hotfix is capable of running without crashes.

1 Like

DX12 is known to be unstable in many games. The Division 1 couldn’t handle DX12 if you have any overlays turned on. The Division 2 is quite stable but would crash sometimes. Ghost Recon Breakpoint crashed a few times for in DX12 but once they added support for Vulkan, I never bothered with DX12. Vulkan is just extremely superior than DX12.

BL3 DX12 have been very stable for me, only crashed one or two times but can’t say the same for my two friends. They have crashed many times with DX12 but not frequently. Now, I’m the one who can’t run BL3 in DX12 at all.

I’m on Windows 10 Pro 1909, by the way. The thing is, this is the only game that refuses to run in DX12 mode completely. Can’t even start the game. Other games can still run and DX12 will break randomly in game.

Could you try rolling back to 1903? I know someone posted about the temp folder on PC a while back - I’ll see if I can find it.

\Documents\My Games\Borderlands 3\Saved\ - Config folder shoud be in here, and one thing you could try doing is moving it temporarily elsewhere to force a fresh initialization.

user\appdata\local\Borderlands 3\saved - I believe the temp data is located in here? Just make sure you don’t delete your save or profile files (backing up is good!)

1 Like

Stop deleting your config files, you’re wasting your time.
Whenever you delete your config file, the game will reset back to DX11 by default. Therefore, deleting the config file every time you start the game doesn’t do anything useful at all because the game is only crashing or fail to start (LowLevelException error) due to DX12 being selected, not DX11.

If you don’t care about DX12, you can go ahead and delete your config file. If you do care about DX12, continue reading.

My game keep throwing LowLevelException error every time I launch it, what do?

  1. Delete everything in this folder: %LOCALAPPDATA%\Borderlands 3\Saved
  2. Start game
  3. Change to DX12*
  4. Restart game immediately.
  5. Game should launch properly in DX12 mode and no longer crashes. Verify that DX12 is selected in settings again.

*Note: If you did not delete your config file before clearing the cache, it should run the game in DX12 mode already. But double check just to be sure.

Got it. Not sure which fixed it. Running the game as admin, or clearing the cache in %LOCALAPPDATA%\Borderlands 3\Saved. Confirmed the game loaded in DX12. Restarted a couple of times as well. I didn’t clear my config or save files in My Documents, so that can be left as they are.

Thank you very much. The game should know that it needs to do this if it crashes at the same part of the launcher a few times.

1 Like

The performance in DX12 is worse then DX11 anyway, so no pooint in running in dX12, it stutters in DX12. DX12 is just a mess, wish they would have gone with vulkan instead.

I have to delete the config every time I start the game or it wont run :confused:

Did you try trashing the local data cache (see a couple of posts up)? That might obviate the need to repeatedly trash the config file.

  1. Delete everything in this folder: %LOCALAPPDATA%\Borderlands 3\Saved
  2. Start game
  3. Change to DX12*
  4. Restart game immediately.

*Note: If you did not delete your config file before clearing the cache, it should run the game in DX12 mode already. But double check just to be sure.

See if it’s crashing again after that. Mine stopped crashing once I deleted the cache files in that folder above.

Not for me. It’s much better than DX11. I do agree that Vulkan would do a much much better job than DX12 regardless.