Forum 500 and 502 Error Codes

If anyone keeps getting 500 or 502 error messages while editing posts or browsing the forums, can you please post:

  • error code
  • date and time error popped up (please include time zone!)
  • browser/version
  • rough geographic location (country, state/province)

Thanks!

2 Likes

“display name internal error”, i can’t play the game i’m on epic games store and whenever trying to put in my name this is that msg I get

Error code 500 while scrolling a thread.
2021-11-18 8:26 AM eastern
Firefox
Toronto

Error code 500 while attempting to move a post to a new thread
2021-11-18 8:30, 8:31, 8:40 AM eastern

2 Likes

When I get those errors, it seems to have something to do with the auto-draft-saving feature. When I get them, I just copy all the text to the clipboard and cancel that post. Then I open a new post, CTRL+V, and submit as quickly as I can. If you get it in before the auto-draft-saving feature activates, you’re good.

3 Likes

This isn’t really the thread for that topic. I tried moving your post to a new thread in the PC Tech Support section but…

Anyway, make sure you aren’t using any non-ascii characters in your display name. If that’s not it, drop a line to 2K and open a support ticket

1 Like

500, 502, you are not permitted to view the requested resource. 5:38-ish through (at least) 6:05-ish AM Pacific, Firefox 94.01, PC, Oregon.

Just got a drafts offline notification on the bottom right of the post box in the RTT, then to see what happens I hit post. It shows saving on an orange bar with an x, while a ghost of my post appears hanging. And now a 500 error. I can still load other pages on the forums, but my likes aren’t being recorded (they either get the you are not permitted to view the requested resource error, or show as if they worked then vanish). After returning and trying to post again, I popped a 502 error this time. I then proceeded here and attempted to post this report, despite not posting the previous post, I get a message for posting too fast, errors (500, 502) accrue sometimes when attempting to post. Additional note, it seems that some of my likes are being recorded, but repeated attempts on one post don’t work. I tried on some earlier posts and they worked. Currently going to go AFK, so I may not be clear when the errors ended. Came back, only five minutes not accounted for, ended sometime after 6 AM.

1 Like

Exactly the same as I’ve been getting. It looks like it’s associated with saving server side for whatever reason.

I’ll foward this thread to the Discourse folks so they can start looking into it. If anyone wants to add in the meantime, feel free to do so. /Phoebe/ I need more data!

1 Like

Errors 500 and 502; Chrome on android phone; 13:30 ish CET, Germany Nov 20

And yes, it took me five attempts to finally post this :face_with_symbols_over_mouth:

1 Like

Thanks. Last I heard was “The engineers have some ideas” so :crossed_fingers:

Edit: they found one scheduled job that was causing database contention and deployed a fix; doesn’t rule out that there might be others though. I’ve sent them your report directly.

502, 4:53ish-5:504ish AM Pacific, Firefox 94.01, Oregon.

Noticed that the forum wasn’t updating for things I viewed, then the post box in the RTT stopped responding. Came here to post and got a 502 as soon as I arrived at the thread, though it didn’t seem to do anything. Got another 502 when I tried to post. Went AFK for twenty, came back.

Appreciate the info. The engineers have confirmed observations on their end, and are working on it.

1 Like

This imply no more need to report this?

Probably not at this point, no.

1 Like