Fps drops from 100 to 40-30-20-15

Can u plz fix this i cant play the game , its fps shoter game

I play on low graphics low rezolution too and i still have fps drops 120-40-30-20

i have a gaming laptop gpu 770m,cpu i7 3 turbo ghz, and 16 gb ram ddr3
i have the latest drivers installed

Ofc thanks for support “” no answear"" better go for refund now

Try going into the video setting and turn Vsync on. If that doesn’t help, go back and change the FPS setting to a set number. Anything other than “smooth”. Should help.

Already did that and this https://steamcommunity.com/app/394230/discussions/0/361787186429140466/

i have to play the game on low all to be abble to play good

I’m having the same issue and have seen other people complaining about it to. In the beta everything ran smoothly but something changed. Now even with almost everything off and on low I jump from 120 to 22 fps. It’s definitely not hardware since I have an i7-4790k and a fury-x. Hopefully it gets fixed soon. I was really looking forward to playing some pvp.

Same problem

You might try turning mouse smoothing off. When I did my frame rates didn’t drop as much and the game ran a bit smoother in areas it stuttered before. Still not great, but better.

Short answer is probably “Ignoring the problem, and also ‘No’.”

Put aside the fact that ALL “AAA Developers” are very, VERY much aware that the vast share of their profits come from console sales (meaning Xbone and PS4), PC ports very rarely see the care they need for a VASTLY different kind of gaming platform.

Gearbox usually does a decent job, though - I just wish they’d stop signing contracts to use Nvidia Gameworks softwarre, thus ensuring “less than ideal” optimization for AMD users.
This behavior always kinda baffles me, as all the major consoles (meaning Xbone and PS4) use AMD tech, and AMD lets is “open source”, so Nvidia would be able to make decent optimization profiles as well…


…But enough ranting and raving: the game is less than ideally optimized, and both AMD and Nvidia users are having issues…

My advice (for as best as I could personally get the settings to have a smooth framerate) would be:

  1. Turn those “Psy Effects” (or w.e. it’s called) down to LOW. These have been reported to cause issues for even Nvidia card users on higher settings…

  2. Turn everything else as low as you can stand it:

  • Turn off “Depth of Field” garbage. Contrary to what you might think due to the fact that it OBSCURED your view, DoF is a graphical STRAIN, not a “releaf”. Also it looks like trash on any game, so… >_<
  • Turn bullet decals OFF. This is a very fast-paced game, and you honestly will not notice them… at all. n.nU
  • Lower your AA settings. Personally I’m very used to maxing these (as my rig is very powerful), but they are one of the largest source of lag here. I can’t reasonably turn them higher than x4 without seeing a large framerate drop…
  • Put shadow quality on “Low” and disable “Dynamic Shadows”. As I said above, this is not a “stop and appreciate the view” kind of game, and you really won’t notice a difference (especially with the “cartoonish” art style the game uses).
  • If all else fails, lower the texture quality. I can barely see a difference between some of the levels of this setting - so much is solid coloring in this game that you can’t tell much of a difference imo.

any update from dev whit optimization problems ? maybe fix ? someting ?

I had the same issue. Hit “alt + enter” to go back to full screen mode after you fire up the game. My frame rate was 144 dropped down to 23-24 and now is back up to 144.

Stop blaming it on AMD gpus, people with NVIDA are having just as many issues, gearbox’s silence on these issues is the real problem, a simple message to your community would go al ong way to showing us you care before we demand a refund.

1 Like

Are my specs not good to run the game ???

Or is the game ?

Try turning off HPET.

  • To enable HPET as the only timer run the command bcdedit /set useplatformclock true
  • To disable HPET in Windows run the command bcdedit /deletevalue useplatformclock

Please check the date on a post before responding. This thread is three years old…