FPS issues with Battleborn

Hi guys,

Hoping you can give me some direction on how to resolve this weird issue I’m having. First here’s the situation:

PC Specs:

  • i7-6700k Skylake CPU (non oc’d, using it at stock)
  • PNY Geforce GTX 970
  • 16gb DDR4 (evga memory I think?, 2400mhz)
  • Gigabyte z170x (gaming-5)
  • ~550ish Antec PSU
  • 2 Samsung 840 Pro SSD’s (where the game is running)
  • 3 monitors (2 Dell 2412m, 1 Dell 20 incher)

I’ve got the onboard GPU enabled on the i7 for Quicksync functionality when using Twitch or other streaming capabilities.

The problem:
Battleborn stays consistently at 20-30FPS in game, it tends to be towards the lower end 21-25fps in almost every single scene I play the game in. This seemed wrong, so after comparing to a few other PC’s with similar specs (i7-4790k’s, i5’s,etc & Geforce 970’s, 980’s) it is clear that I should be getting close to 50fps at the least at 1080p.

Troubleshooting ENGAGED!:

Tried a number of things but first I tried to identify a problem. Fired up GPUZ and EVGA PrecisionX to attempt to monitor the problem. The graphics card immediately showed me the issue. The GPU stays stuck at 848mhz or 1050mhz core clock no matter what. It will NOT run at full speed (12-1300mhz, depending on turbo clock) with gpu or memory on the GPU (memory stuck at 1780mhz). I then proceeded to test the following:

  1. In game, set every graphical setting to low or off, set resolution to 1920x1080, ensure graphics card driver had all settings set to off.
  2. Attempted removal of drivers for Nvidia, using DDU and rebooted to safemode for removal. Reinstalled latest Nvidia drivers - 368.22
  3. Attempted removal of drivers again, next used older march driver (364.72).
  4. Attempted using a single monitor for all gaming.
  5. Attempted using Lower resolution of 1280x1024 or less.
  6. Attempted shutting down Intel GPU within the BIOs.

Finally the results and possible theory?

So upon all these tests I discovered that the GPUZ would showcase the PerfCap reason as “UTIL”. Now this suggests that the Graphics card has been fully utilized, which it obviously isn’t maxing its core capabilities or memory bandwidth, I then decided to compare this to other games that have no issues on my PC. I loaded DOOM to discover that it was VREL perfcap or Ark, again VREL perfcap reason. This suggests to me that somehow the game is not working properly with the driver. I then decided to attempt one last time using the following set of tweaks:

Again no joy with these tweaks enabled in the ini files on the game.

There has been several posts on reddit/steam/etc, that seem to suggest an OS reinstall would solve the issue. I will make an attempt with this as soon as I have a spare drive (incoming shortly). I will not replace this OS permanently with it, but I feel in the interest of good troubleshooting/helpfulness with the game community this maybe useful to know the results.

So with all of this having been performed, is there any additional support team info that you could provide? Any checks, debugging mode or some kind of logging I can generate that might be helpful to the support teams? Let me know what I can do to help document this weird issue.

1 Like

Nothing? No ideas here Gearbox support? No help to offer for checking further? I’m about to attemp the OS reinstall if this doesn’t get some additional input this week.

Checking in here. I have a 980ti too and get around 45fps with settings even on low. I’m trying to figure this out too and I’m finding there are many high end gpus that are having a problem. If I watch the usage of my gpu it never goes above 40% which means the game isn’t even using what it should.

1 Like

Well thats good to know I’m not the only one. If I may ask, what is your platform specs? Is it also an i7-6700k?

Haven’t been able to play the game since purchase. Everything is fine until the character selection screen and it drops to 7fps and is always around 7-10fps. Have tried driver uninstalls, different versions, reinstalling the game, changing every option to the lowest setting including resolution, nothing works. Checked the GPU usage and it’s always at 0% except for the odd spike to 100% for a split second. Every other game I have, Overwatch, Doom, and so on play as expected with my spec.
Really feeling like I wasted my money on this game at this point.

My PC specs:

i5-6600k Skylake CPU

  • AMD R9 390 video card
  • 32GB DDR4
  • Gigabyte z170x (gaming-5)
  • 750 EVGA PSU

im still having problems with performance on my pc aswell. i play for about an hour then game gets really choppy and stuttery and is unplayable. Have hardly played since i bought it last week. i have an nvidia gtx 970 graphics card.

Really hope the devs can fix this soon.

I’m on an x99 deluxe board with a 5820k.

Great, so its not even hardware or vendor specific in nature. I was hoping for some commonality in the overall set of affected systems, but it seems like it has to be the game. Ugh…

Interesting that Nazrule has a similar system and motherboard to myself. Wonder if thats any issue.

Well just to give an update I did a windows 10 reinstall even though every thing has been working perfectly on my PC since upgrading all my parts a few months ago except for Battleborn and I hate to say it but it fixed the FPS issue. This is even with the AMD drivers from DEC 2015, haven’t even tried the newer drivers yet. Character screen select went from 7ps to over 100 and the few min in game for the prologue is 40-100 but thats with old drivers. Anyways just throwing this out there for anyone that at least wants to try to get this one game working if having unplayable frame rates on high end hardware.

Same here, fps drops in prologue to 10…
Unplayable since his launch…
Opened a support ticket
Devs told me i havent the minimal spec …
But i run Borderlands in very high and recently run overwatch(same minimalspec) at 50-60 fps in"high" mode…
So Devs dont tell me i cant run you creepy game !!!

FWI : i reinstalled windows 10 and it did nothing more…
What about you seanfalconer ??

I am waiting for this weekend to do a system reinstallation. I will have to buy another hard drive to make this work, but ultimately I just want to see if it does fix the issue. From my specs, I can’t imagine i’m not able to run this at 50fps. What are your specs Walzahel?

I’m seeing the same symptoms.

i7 6700k
GTX 1070
16 GB Ram
Windows 8.1

I’ve tried uninstalling, reinstalling, removing every copy of visual c++. Messed around with all the graphics settings, never got any boost in performance from them though.

So I finally tried the original suggestion of an OS reinstallation. I’ve gone from Windows 8.1 to Windows 10 64-bit. The reinstallation has resolved all issues with the game. It now functions without issue. So that tears it… if you are still having issues with the game, then an OS reinstall does solve the problem.

Its a VERY ridiculous and extreme measure though, and I’m sorry it took me so long to get to the results here. Gearbox, there’s clearly something wrong here, please can you reach out to do some additional testing with folks to find out why/how this is such a problem?

I did a reinstall a while ago and it solved my issue as well.

Sorry to be a bother, but how do you reinstall win10? My friend got the pc version for me so we could play together, and I have a really hard time keeping up. Anything I can do to make the game run even a little smoother?