Frame Limiter Broken

For some reason the built-in frame limiter is all mixed up. The 50 FPS limit option caps my framerate at 60 FPS, 60 FPS caps at 50 FPS, 120 functions as the custom frame limit option and so on. They’re all wrong. Anyone else having this issue?

Yeah, they messed it up. I think today’s patch resolved it though.