Game does not save at all *Enhanced Edition*

Whenever the game launches I see the terms and conditions every time as if the game is new. Importing characters doesn’t add them to the roster. After playing the game and ‘save and quit’ it does not save the character.

The correct save folder is present and active. INI files save fine. Have run game as admin. Have reinstalled. Have added save folders and game folders to AVG exceptions.

Possible causes - My Documents folder moved from original position, but have created a folder in the C:/ drive with the correct path it would normally save in anyway.

Game is unplayable at this point. It just won’t save any data.

Double check the full path to the location it’s trying to use for the save games, not just the short-cut version. Someone had a similar problem recently and it turned out that Windows had helpfully decided to move all documents to One Drive (except then the absolute path didn’t match and chaos ensued.)

Also double-check that the folder permissions aren’t being reset. You mentioned AVG exceptions - was that 3rd party AV software, or the built-in Windows one? Sometimes the anti-malware stuff gets a little huffy.

Not using OneDrive at all.

Savegame folder has been created right up next to others which all work.

image

Opened AVG app in order to manually add exceptions through the app itself, not through windows.

What are the permissions on the BL GOTY folder?

Only one user account and it’s admin. Checked permissions and all access is allowed. It’s ‘read only’ but so is the entire folder and other games save fine. Have tried to disable read only but it re-enables, not sure if this is the problem though as other games work.

That sounds like Windows Defender anti-malware. Maybe give it a poke? If that doesn’t work, you can file a support request here:

https://gearboxsoftware.zendesk.com/hc/en-us/requests/new

How to add this to exceptions on Defender?

Not sure, but I know this has come up before. Should be a knowledge base article about it somewhere, and I know it’s been mentioned here on the forums as well - hopefully Google can find it for you.

Disabled Windows Defender using regedit. Still doesn’t work.

Others reporting issue here

That’s not the best way to do it! Try this instead:

https://support.microsoft.com/en-ca/help/4028485/windows-10-add-an-exclusion-to-windows-security

This error appears every time and I have admin privileges, these options are all missing.

image

Sorry, but that’s about as far as I can get you. I’d suggest opening a ticket with the support desk using the link I gave you in post # 6.

Definitely seems like the game is broken since have three other Borderlands titles all working and saving fine.

Also done today, which fixed the problem.

Uninstalled AVG. Got into WinDefender, put folder exceptions for install folder and save files folder, exe of launcher and exe of game.

image

Also restored default location of ‘My Documents Folder’ into C: drive. This was done using a .bat file downloaded from here -> https://www.tenforums.com/tutorials/23504-restore-default-location-personal-folders-windows-10-a.html

After confirming this worked, I reinstalled AVG and the game runs correctly.

CONCLUSION: This still needs patching to fix the My Documents folder problem at the very least.

Where was it pointing originally - to the E drive on your system?

Yeah it didn’t like saving to any other drives - or it was indeed WinDefender that was stopping it saving there. Hard to tell which was the actual cause.

Both are buggy and worth looking into. For some people changing one works and for some changing the other seems to work when encountering this issue.

Sounds like more of an installer thing, which would be Steam, than an actual game thing? WinDefender is pretty picky about folders where internet-connected applications read and write, thanks to the plague of ransomware going around. In a way, it’s a good thing, but it’s a pain for games with an on-line component.

Whatever it is dev should look into it/publish info on the problem, fixing took very long. Not much info out there online on the fix, had to do most of this manually took like 6 hours total troubleshooting.

Zendesk support doesn’t even reply in 14 hours. Had to do it by myself. Amusing. Also Windows 10 pretty garbage anyway that you have to uninstall antivirus to change Defender settings. Idiots.

I realize this post is old but I did want to add that going into the “my games” then “borderlands GOTY” folder in my documents and deleting everything but the “binaries” folder helped me fix the game.

It wasn’t saving and then it also stopped starting, all in the same day, at the same time. Doing that fixed both issues for me (didn’t do anything above), so that might be something for people to look at first since it’s much simpler.

Credit for that goes to this wonderful person: https://steamcommunity.com/app/729040/discussions/0/1813170373214967591/#c1679189548051628501

Note: The binaries folders is what has all of your save data in it (if you still have any) - so you won’t lose that progress by doing this.