Game freezes and becomes unresponsive in New Game cutscene

I recently purchased Borderlands 3 for Mac (please no Mac hate, I can’t afford a PC right now). I knew that there were some optimisation issues but I managed to get the game running smoothly at an acceptable graphics level, using the main menu and the benchmark test and by consulting many online forums (including this one).

However, upon starting a new game, at a certain point in the opening cutscene, the game will freeze and stop responding, requiring a force-quit. The audio continues in the background. I have repeated this about 20 times and it is always the same point: soon after FL4K’s title card and just after Moze throws a bandit through a window (screenshot attached). This is just a minute or so before what I believe is the character selection screen.

I have noticed that the CPU usage from the Borderlands 3 app is quite high in this opening cutscene (~160%), but that seems normal. When the crash occurs however, it drops to 9% and a process called MTLCompilerService jumps to 99%. I’ve also noticed that the game only uses up to 2.2 GB of RAM in this cutscene.
My computer is not exactly high-end, but I have seen many other Mac users run this game fine on older and less-powerful models.
The strange part is that I can’t seem to find anyone else with this issue, hence why I’m making this post.

Things I have already tried:

  • rebooting
  • reinstalling BL3
  • installing in a different location
  • installing on a different user
  • changing many in-game settings (these helped with FPS drops, not with the freezing issue)
  • adding a few command line arguments from the Epic Launcher

Any help would be greatly appreciated. I have been looking forward to playing BL3 for a long long time, but this freezing issue is holding me back.

My specifications:

  • MacOS High Sierra 10.13.6
  • 2017 15’ MacBook Pro
  • 2.9 Ghz quad-core Intel i7
  • 16 GB 2133 MHz LPDDR3
  • Radeon Pro 560 with 4 GB VRAM
  • Running BL3 using the Epic Launcher

UPDATE:
Tried a few other things:

  • Installing in Applications folder instead of a location in Users
  • Disabling automatic graphics switching
  • Upgrading to macOS 10.14 Mojave

And the last one worked! Now I’ve got some FPS issues, but at least I can play the game.
Seems like it was a problem with High Sierra.