Game locks and crashes following May 07 2015 Patch

So the May 07 patch fixed the freezing and stuttering when using the UI Research menu, great.

Shame that it is now constantly locking up / crashing at random forcing a hard reboot every single time I try to play :tired_face:

Description
A problem caused this program to stop interacting with Windows.

Problem signature
Problem Event Name: AppHangB1
Application Name: HomeworldRM.exe
Application Version: 0.0.0.0
Application Timestamp: 550c699b
Hang Signature: cd4a
Hang Type: 0
OS Version: 6.0.6002.2.2.0.768.3
Locale ID: 2057
Additional Hang Signature 1: 65c720d8cf142c8727e3c9832d76a8d0
Additional Hang Signature 2: b1f1
Additional Hang Signature 3: 306406844362c4370640688e708c1e06
Additional Hang Signature 4: cd4a
Additional Hang Signature 5: 65c720d8cf142c8727e3c9832d76a8d0
Additional Hang Signature 6: b1f1
Additional Hang Signature 7: 306406844362c4370640688e708c1e06

I had thought this had resolved itself as I had two sessions on HMRC in the days that followed but it has started again today.

Other than the patch I have made no updates to the PC O/S or current drivers and I am able to run numerous other games and applications without any issues and everything is stable. The crashes only occur when running HRMC.

Anyone else having the same issue or know a fix? Six attempted to play vs CPU today and six crashes within 20-30 mins of play.

If you aren’t online (MP, etc) - at which point it can be things like De-syncs and such, then the only major factor (generally) will be RAM. Try turning down your texture settings?

Thanks for the response, I will try turning down textures but I would not of thought it would be the issue, recommended memory is 4Gb.

I’m running 8Gb RAM with a further 4Gb on the Video card and as I say I’ve never had a single HRMC crash in over 170 hours of play time until post May 07 patch.

Each time it has happened I have only been launching multi-player beta and playing games vs CPU. I haven’t dared go back to play more MP player vs player while this has been happening in case it locks and forces a restart while playing actual opponents.

Game cache integrity is fine, I’ve checked that twice.

If and when it happens again I’ll check through my router logs and see if there have been any events with timestamps to match a crash in case de-sync is an issue.