Game loses connection to Steam or kills WiFi connection

So my game on PC has been working fine for roughly three weeks, all was good however it them started having issues.

First, it was that it didn’t want to load a default character when I skipped the initial screens to get to the main menu and from there, trying to continue a game caused it to generate a GetOuterMost() error - file not found when loading, crashing the game.
After switching USB posts this seems to have fixed it (no idea why)

Second issue was that it would lost connection to Steam and thus keep d/cing a friend who’d be playing with me or I’d drop from a game they’re hosting. What became more serious was that it would actually cause my wifi connection to disconnect completely so it’s not simply a problem connecting to Steam but something seems to be messing with the wireless adapter.

Borderlands 1 works fine in the same setup.
Every other game I have that does online co-op and uses a pad works fine.

I tried :

  • to get profile.bin to regenerate itself.
  • checking permissions to the save game folder
  • complete reinstall of the game

All methods have not resulted in any success. I’m somewhat at a loss to imagine what could have changed that would cause it to play up like this after 3 weeks completely stable.

1 Like

What version of Windows are you on? There was a very recent Windows 10 update that changed some stuff for some people (mostly different driver versions).

1 Like

Windows 10.

Any idea which update I should be looking to rollback?

Interestingly, my update history only shows stuff from early to mid November. The only one that might be impacting is an Nvidia update.

1 Like

See if you can find out anything about the NVidia one - graphics driver updates seem to cause problems

1 Like

MS has been sending out the Fall Creators Update in waves. One of my computers got it a couple weeks ago; another is getting it now. It’s version 1709.
My computer has been buggy in the day leading up to it, so the download might actually help.

Wow, did I actually just say that? :face_with_raised_eyebrow:

3 Likes

Well, tried a rollback (there were no release notes attached to the update sadly) which still hasn’t 100% fixed it. I can’t say for certain if it’s more or less stable now. It’s almost like when you have a ball that’s bouncing and then settles after a few minutes. Strange…

I’d heard of this but I can’t seem to find it under add/remove programs and windows features, can ya point me in the right direction?

This is probably a wild goose chase but :
Start – Settings – Updates & Security – View installed update history

That’ll tell you what version you’re at.
If you’re at 1709, that’s current and I don’t know how to roll it back.
If you’re at 1703, then you can go to the MS site to download the FCU.

Also if you let Windows update your video driver, instead get it from NVidia.

Another issue I had specifically with co-op ( but not wifi ) was with Windows firewall. I had to disable it to host ( which is fine because I use a 3rd party firewall ).

1 Like

Ok so I’m at 1709 which should have been stable afaik… honestly would prefer to disable it if I could but can’t find it in the uninstall updates list further on from that view.

I’ll see how I get on with the previous driver; to be fair if that’s rendering fine to me then that at least takes that out of the equation.

Firewall seems all fine; no change when it was disabled and my steam games already have an exclusion rule.

Will try a proper session again later, see if it’s quirked itself back to normal or not.