Game opens on the wrong monitor, doesn't detect my main display

I have 2 monitors, 1 is my main display in landscape (DELL S2417DG 144Hz), the second is in portrait (ASUS PB258 60Hz). Both run 2560x1440 and both work fine in windows. They are connected to a GTX1080. I’ve updated to the latest drivers as of today from nvidia website 436.30.

When BL3 opens, the intro movies play on the main monitor as expected. When the “engine” kicks in, after the unreal logo scene, the game opens on the second monitor in portrait mode.

When I go to the visuals settings, I can’t select any other monitor for the target display. Would appreciate any assistance. I can’t get the game to run on the correct monitor right now.

4 Likes

I have the same issue. I have been able to force it to the main screen at least temporarily. If you set the screen mode to Windowed Borderless and apply the change. Then press Shift + Windows Key + Left arrow (or right depending on the layout of your screens) the game will jump to the “correct” monitor. I will say that this solution is not perfect. I do get some weirdness where the mouse seem to lose focus of the game and clicks on things on the desktop or sometimes during a cut scene the game jumps back to the “wrong” monitor. Then I have to repeat the keys about. Hope this at least helps get you playing til they fix this.

I have also updated my drivers.

I’m also having the same problem and can’t find any answers.

Same here. When I have both monitors enabled, it only lets me select one under Visuals > Target Display. If I disable my secondary monitor, it launches on my primary, but shows up like this:

2 Likes

I remember this happening with another game, so I suspected maybe unreal engine related!m
Anyways I found a similar post on reddit for Fortnite, also using unreal engine: https://www.reddit.com/r/FORTnITE/comments/6q35d1/game_constantly_opening_on_the_wrong_monitor/ (UPDATED WITH CORRECT LINK, SORRY!)

I was out of ideas so I did everything in here… I changed the cable ordering on my monitors, repositioned them in windows display control panel etc I rebooted my computer and now my DELL monitor is discovered by the game and so far so good. Try these tips out and let us know if you still have issues.

I had the same issue. I fixed mine by installing the correct driver for my monitor.  I had to download and install the driver manually using device manager (Dell AW3418DW). Using windows to auto find the best driver was just installing the std plug & play monitor and did not fix the issue.  I had this issue in the past, mostly with 2 or 3 mon setups with different Refresh rates.

I got the game to properly detect my Primary monitor this morning. YMMV, but here’s what worked for me.

I noticed that the Windows Device Manager was listing my primary monitor as Generic PnP, even though it lists it by name in my Display Settings, and the NVIDIA Control Panel. If the same thing’s happening to you, try the following:

Download your display drivers from the manufacturer’s site and reinstall them through Device Manager:

  • In the Device Manager, under Monitors, right-click Generic PnP and do “Update Driver”
  • Click “Browse my computer for driver software”
  • Instead of picking a folder where it says “Search for drivers in this location:”, click the option at the bottom that says: “Let me pick from a list of available drivers on my computer”

Selecting the folder under “Search for drivers in this location” failed for me every single time, but when I did the bottom option and navigated to the same folder, it worked the first try. Now both of my displays show up in-game:

1 Like

I got mine fixed. Acer doesn’t have signed drivers so I had to reboot my computer and disable signature verification and install the proper drivers. Now it recognizes both and I can play the game!

Anyone have an idea if you can’t find any drivers to download from the website? I’m using an Asus monitor and their site doesn’t have any drivers for my monitor. Having the same problem, game doesn’t detect my primary monitor.

Try setting the game into windowed mode at a smaller resolution so you can see the X at the top right of the window. Move the game to your primary monitor then hold down the Shift button while pressing X to close the game. That should help windows to remember what monitor you want it on.

1 Like

I had this same problem. I solved it by updating my GPU and main monitor’s driver. Never trust window’s automatic update, as I checked both my GPU and monitors drivers manually and they were both several versions behind.

Hello! Since the 1st day I have a problem running Borderlands 3.
I have 3 monitor setup and the game sorta runs on each one but main monitor. It runs on my Benq EL2870U but only in borderless window mode, cannot run in Full Screen mode. And ASUS VG248QE only full hd but in portrait mode. My main monitor is Benq RL2460HT and it definitely cannot run. I manually downloaded and updated latest Nvidia and Monitor drivers, still doesn’t work. I tries disconnecting/conneciting/swaping all hdmi/display port cables and still didn’t work. Also in Visual settings in game there are both Benq EL2870U and Asus VG248QE list but my main (Benq Rl2460HT) isn’t. Only time when I was able tu run the game on main monitor (Benq RL2460HT) was when I completely disconnected every other monitor and still the Visual menu in game listed it as ‘Unknown’. I was trying to fix the problem for 3 days, searched over the internet, found few similar problems but still no fix. I tweaked every option for resolution and refresh rates in game and in windows but nothing fixes it.
The 2k, gearbox and amd animations run ok, but at about half of the claptrap loading animation game just swaps to another display and stays there. Also I tried to put it in windowed mode and manually drag it to main display and when I try to full screen it it just jumps back to other monitors. I literally tried every solution but no fix…Please help me out.

Thank you in advance

1 Like

This doesn’t help when your main monitor is 4K and you want to play fullscreen 1080p for performance reasons :confused:

my main monitor is full hd and I want to play in full hd, 4k monitor is the side monitor

ugh
The thing about Asus Monitors is they don’t really come with any drivers to install. Never have. They’re just standard PnP monitors and Windows 10 is unable to identify them as anything else. A simple fix for this would be if you got to select the target display, even if that display is an unknown one. Seriously, would that be so hard to patch in? My secondary monitor is a tiny square-shaped Dell, but because the game can at least identify it it insists on displaying the game there. It’s maddening. And no, starting the game in window mode and dragging it over to my main display via shift/windows/left doesn’t really help because the resolution differs so greatly. Just make it so I can pick the Unknown display and don’t have to unplug my secondary monitor all the time. Please?

Same problem, but my secondary is an HP W2081d in portrait mode. My primary is a Hanns.G HH281HPB that has LITERALLY no drivers for Win10 anywhere that I can find. Without physically unplugging the DVI cord from my secondary monitor Borderlands 3 will not run on my primary monitor in anything other than windowed mode. If I wanted to get it to do that I have to start the game, set resolution to 600x400 (or what ever the lowest it will let me is), change to windoed mode, drag it over to my primary, then play with the resolution till it kinda sorta fits my primary monitor. Either give me the option to select “unknown” monitors or a way to turn monitor targeting off altogether.

1 Like

win button + shift + arrow left or right.

WOHOOO! They patched up the problem. Fired the game up today and lo and behold it recognizes all my monitors.

With todays steam release, this issue is still present.

I also have a three monitor setup in use. One 4k monitor as primary display and two 1080p monitors as secondary and tertiary display.

When I start the game, the 2k and gearbox logos, also the dancing claptrap is shown on my primary display in the correct 4k resolution.

After the intro logos, when the game engine starts, the game switches to one of the 1080p displays.

In the game options i can only switch between the two 1080p display and i can see their correct model numbers. But the 4k Display is not recognized or shown.

Even if i try to force the preferred display setting in the config file, the game switches to one of the 1080p displays and didn’t recognise the 4k display.

For testing purpose, i’ve deactivated both 1080p displays, so that only my 4k display is active. When i start the game now, the “target display” is shown as unknown. And although it’s showing an autodetected 4k resolution, it’s only a 2k resolution according to my osd from my monitor. If i switch the resolution back to a lower resolution and then back to 4k, it finally switches to the real 4k resolution visually and proven to through the monitors osd.

Having to deactive additional displays in order to be able to play the game is not an acceptable option. I need to be able to use the other displays while ingame.

I have updated to the latest gpu and display drivers, but it’s not an issue with drivers. I don’t have this issue in any other games, not even in Borderlands 1, 2 oder Pre-Sequel. It’s just an issue with Borderlands 3. And it’s very disappointing, that this issue haven’t been fixed, after such a long time since the game have been released.

3 Likes

I am also having this issue, launching through Steam. I manage my main monitor for gaming through NVIDIA GeForce Experience, but right now GeForce isn’t recognizing that BL3 is installed. Weirder still is that my main overall monitor is also now set to my gaming monitor, and it still launches on the other one.
I have the bugs that others mentioned above - can’t switch monitors in the drop-down in-game, can’t play it in Windowed mode on the other monitor. It was also using the wrong graphics card. I had to unplug my extra monitor to make the game launch with the correct monitor and graphics card. Now it’s saying “unknown” for the target display.
Please fix it :slight_smile:

1 Like