Game says "Epic Must be running in order to launch Borderlands: The Pre Sequel" after cutscene

I got Borderlands: The handsome collection for free from the epic games store. When I launch Borderlands: The Pre Sequel from the EPic Games store and starting a new game and after the ending of the opening cutscene a popup appears saying “Epic must be running in order to Launch Borderlands: The Pre Sequel” . I have searched everwhere and tried the following :-

  1. Install Visual C++ Redistributables
  2. Install DirectX 9 from here
  3. Rename BorderlandsPreSequel.exe to Launcher.exe and renaming Launcher.exe and when they did not work rename it back to original
  4. Verified the game files with Epic Games Launcher
  5. Run Epic Games Launcher as administrator
  6. Run Epic Games Launcher in windows 8 compatiblity mode

However after this the game would display the same popup

How do I fix this?

I grabbed this up for free as well and had a similar issue with bl2. Granted I was playing with the hex tool to run the community patch. A simple reboot fixed it, but I haven’t tried TPS yet.

I’d suggest putting in a ticket with epic support. Maybe reinstall if you haven’t tried that already (delete any leftover files after the uninstall).

Okay I will make a ticket with epic support

Caught this in an unrelated thread. Seems there’s an error in a dll file associated with linking to shift. Might do nothing, but worth a shot:

Edit: I know it says steam, but the same fix works with that error on epic.