Gameplay Bugs & Feedback MEGATHREAD

Yap both in vanilla Homeworld1 and the remasters this bug is present. In vanilla it probably was never intended that you could rescue the sixt pod. But it was possible even without cheating. ^^ :stuck_out_tongue:

Anyway in vanilla the game was stuck then as the script never finished at least in the remastered the script did finish and the hyperdrive button appeared but of course still missing the proper sound lines as mentioned above.

Saving that sixth cryo tray back in the original always felt like such an achievement…Like you’d got one over on the Game by saving all those extra souls :slight_smile:

Are you sure about this for the original Homeworld ? I could have sworn I’ve saved all six trays and then heard this bit of script on several occasions or at least have no memory of it not happening.

Then hyperspaced onto the next mission… Or are we talking about something different ?

No we are talking about the same thing and yes I’m sure… You could never saved more than 5 in vanilla. Also if you rescued only 4 cryo trays then it skipped from 300.000 people safe to 500.000 people safe on number 4. So that you still had your minimum of 500.000 people safe and sound.

Really? Granted, it’s been a while, but I swear I managed all six.

Minor bug in HW2 Remastered:

  • In Mission 05, if you make a save after progressing towards the dig site, then reload it, the enemy will start sending probes, even if they didn’t do anything of the sort before reloading the save. This makes it impossible to reach the dig site without being detected and resulting in heavy losses that will probably result in mission failure.

I have made it my primary objective in that mission to save all 6. If I don’t, the mission is a failure and I need to restart.

I have been able to do this consistently in HW1 vanilla thanks to salvage corvettes and I was able to do this in HW1R by grabbing the damaged cryo tray before the cutscene started so the assault frigates would chase it into the rest of my salvage corvettes.

1 Like

As it was bothering me that my memory could be so off track, I’ve just fired up the classic version to test this out.

It seems saving all six cryo trays does Not affect that piece of script delivered by fleet command and the hyperspace button Does become available.

Whatever caused that issue to occur in your play through of Homeworld classic would seem to be either unrelated to the number of cryo trays collected or perhaps extremely intermitant in its nature :confused:

If this now happens in the Remastered version (have not checked yet) it should be considered a completely new bug of some kind.

Somewhat unrelated whilst conducting this test every time I shut down Homeworld Classic then re-launched it. It would reset to the minimum screen resolution on the list. with seemingly no way to make it remember the previously selected resolution :confused: …Just me ? or does that happen for everyone ?

Homeworld Classic saves it’s settings in the registry and there’s issues with Windows 8 (And maybe older versions) and permissions to set those values. You have to run it as Admin for them to save properly.

I had to fight with that to get it to run widescreen.

2 Likes

Thanks :smile:

I’ll check it out, now I know what the issue could be…though I’m using windows 7 if that makes a difference

…this is brilliant.

Well the last time I tried it in HW1 vanilla was on the old CD version. Perhaps they fixed it for the remastered classic re-release but I still doubt it.

As stated before in my vanilla cd version patch German v1.5 when you did capture all six of them nothing else happened.

And yesterday when I did it in the remastered HW1 campaign the hyperspace button did appear but it skipped the last 2 audio lines.

“600.000 people secured”

“Cryo trays loaded and secure. Hyperspace module charged. There’s nothing left for us here. Lets go.”

Again I could hyperspace out I was just referring to the missing audio perhaps you misunderstood that.

I just realised I’d used the term Fleet command, when I meant to say Fleet intelligence with reference to the last line of script which probably hasn’t helped :blush:…But having said that concerning the classic version.

The “600,000 thousand” line thats spoken by Fleet command (karan s’jet ) is I agree not spoken and has to my knowledge never actually existed.
Which when they went to the trouble of bringing back in the original voice Actor ( Heide Ernest ) seems like a strange little oversight not to have corrected…

However the next Line…

spoken by Fleet intelligence (Michael Sunczyk) occurs 25 seconds after the hanger door closes on the last tray assuming the frigate has already been captured and processed by this point.

I had a save point halfway through the loading of all 6 cryo trays, which I’ve ran 5 times in a row. all with the same results which would suggest the audio error you experience is probably caused by some other trigger than the 6th cryo tray. Which is quite interesting.

What was your fleet composition at this point ? did you load all the trays before you captured and processed an enemy frigate ?
or perhaps its even Mod related ?

I’m as close to positive as I can be without digging out my old disks that this didn’t happen back in 99 so it must be something that’s happened to HW:RM in the transfer to the HW2 engine. :confused:

1 Like

You can’t get proximity sensors to ‘guard’ a ship, like in the original (if you’re trying to play it properly and detect stuff etc).

I don’t know if this was already reported by someone else, I did a quicksearch on the thread before posting and didn’t find this bug, so I apologize in advance if I am repeating things already mentioned before.

Just played Mission 14 of HW:R 1 and after destroying the Inhibitor as well as all 3 hyperspace gates the mission doesn’t end, there is no hyperspace button and the objective marker still says I have to destroy the inhibitor even though it is gone.

The first time I destroyed the inhibitor it worked and I was able to end the mission, but I had to reload an earlier save in order to capture the enemy battlecruiser which I failed to get the first time :stuck_out_tongue:

I started the mission with the current patch installed, so I didn’t load a pre patch 2 savegame or anything, I did however load the earlier savegame during the hyperspace sequence at the end of a mission and I also skipped the long animated sequence around the inhibitor since I had already seen it minutes earlier ^^. Don’t know if that might be the cause (tho it shouldn’t) or if its something else entirely that caused it.

If anyone knows a workaround/fix or if any dev needs more information from me, let me know please :slight_smile:

Also I wanted to mention that the soundbug still exists where the fighter engine sound is constantly playing after zooming in on a carrier or mothership while fighters/corvettes are docked. Only way to fix it is to press F10 and go to the menu, which can get pretty annoying :slight_smile:

1 Like

Not sure if anyone else has mentioned this, but I would assume this to be a bug:

Has anyone noticed that the Pride of Hiigara seems to be far more powerful than it used to be? In Classic, particularly in MIssion 06, it was quite easy for the Pride to be overwhelmed by the Movers and could actually be destroyed. In Remastered however, the Movers are swarming the Pride and hardly doing any damage whatsoever and the Pride seems to shrug it off like it’s nothing. I don’t get it: why is the mothership so strong (including the upgrades?) compared to its Classic counterpart? That needs to be looked into for balancing imo.

It’s actually the movers that are weaker. I remember till you salvaged that mover wreck that I had to constantly build new squadrons in vanilla… In the remastered edition I barely had casulties at all and once the research was uncovered almost 0…

2 Likes

Since cloaks don’t do diddly either, it doesn’t really matter. But I used to love putting a bunch of them in a sphere and let them dance, guarding a ball of something else.

I’m having the same problems with Bridge of Sighs as well, having entered with 24 HCs. They finish the inhibitor quite thoroughly, but it doesn’t get recognized and I can’t exit.

I actually managed to finish the mission by loading an earlier savegame in case that helps, the save was around 2 minutes before I started attacking the inhibitor, so if you have one around that time, try playing from that point and see if it works.

I was pretty easily able to do this with salvagers as well. Assault frigs first, cryo trays after :slight_smile: