Goblins not showing up

Hello guys,

So after adding the details to my main ship mesh, this happened:
image

Then I tried these details as goblins, I looked at the hgn_carrier to find out how it should work.
But they never show up in the game, I already tried to tweak the settings for them in the .ship file, no success.

HODOR takes much longer generating the scene data, so they are in the .hod.
They also show up in CFHodEd.

Do you have the goblins bit in the .ship file?

1 Like

@Dom2 Yes I do.

Thank you for the answer, but I fixed it some minutes ago.
I just put the details into another joint. Now it works perfectly.

I wonder if you were just overflowing the vert/polygon limits of conversion. If you have the ‘broken’ file, I’d love to see it. When I do RODOH/HODOR work again, it could come in handy!

1 Like

OHHHH I’ve seen a model do this to me before.

Having way too many verts/ploys could have certainly be the issue.

Edit: Holy ■■■■, the highest detail version has 87k verts, no damn wonder.

1 Like

Yeah, the GL buffers we use are short… so a single mesh hits 64k tops. And with splits/dupes you may need to consider 50k tops. I am thinking I can make HODOR auto-split to solve it, just have to find time.

2 Likes

@BitVenom
The main mesh and the details together have 36k vertices.
I guess you want the dae that generated this mess: ter_tokyo_messy.zip

And by the way, a friend from Phoenix Interactive told me that one of their meshes has 97k vertices.
They split up the mesh in several parts and put them into separate joints.

whats a goblin

well you don’t have to worry about them after the 2.0 patch because they were made pointless. Goblins were basically another implementation of LOD. the further away you got from the model the less detail was loaded.

1 Like