Got legendary gear, but it's grey?

I opened a rare pack and got the run to recharge shields legendary, but it’s greyed out and when I tried to buy it in a match, I can’t cause the button for it isn’t there. Help?

Picture please?

How do I get pic? I’m on ps4?

Do you have another gear piece of that type equipped? You can only have one of a gear type equipped. Only other reason I can think is it is temporairily disabled because of a broken mechanic, although I haven’t heard of any pieces having that done since the Beta.

No, it’s my only soda bottle looking one.

I think he’s talking about this:

I got one too, from a legendary pack in the DE. I haven’t tried using it in game yet. It’s just grey, has been since I got it t.

1 Like

Yeah, that’s the one.

Basically, there is a bug with the item that creates some form of imbalance. So, they have been temporarily deactivated until they are fixed. This happened during the beta as well. Hope this helps.

Ok. Thanks for all the help.

Same problem, its disabled till they fix it.