[HELP] Implementing new FX and ran into crash

Hello,

I am working on custom FX for my mod. I finished editing all the necessary files for a new weapon and implemented the files into their correct places, but I’m getting the “General Failure” crash when trying to test the new FX out. However, when I check my “HWRM.log” it has no record of the crash…

I’ll post the HWRM.log here just in case I am missing something, should I attach the error log and all the script files for my new FX as well?

HWRM.log:
Tue Dec 20 19:28:19 2016
 Version 2.1, Build Number 31, Changelist Number 1237961 
 UTIL -- filepath failure, path doesn't exists 'C:\Program Files (x86)\Steam\steamapps\common\Homeworld\HomeworldRM\TheEcho\locale\English' 
 Loaded Archive: 'Homeworld2.big' 
 Failed to Load Archive '..\..\DATAUPDATES\UpdateHomeworld2.big' 
 Loaded Archive: 'HW1Ships.big' 
 Failed to Load Archive '..\..\DATAUPDATES\UpdateHW1Ships.big' 
 Loaded Archive: 'HW2Ships.big' 
 Failed to Load Archive '..\..\DATAUPDATES\UpdateHW2Ships.big' 
 Loaded Archive: 'HWBackgrounds.big' 
 Failed to Load Archive '..\..\DATAUPDATES\UpdateHWBackgrounds.big' 
 UTIL -- filepath failure, path doesn't exists 'C:\Program Files (x86)\Steam\steamapps\common\Homeworld\HomeworldRM\data\locale\English' 
 Loaded Archive: 'English.big' 
 Failed to Load Archive '..\..\DATAUPDATES\UpdateEnglish.big' 
 Failed to Load Archive '..\..\DATAUPDATES\Compatibility.big' 
 Uing ..profiles\ for profiles folder 
 GAME -- Using player profile Private Hix 
 Changing from a 32 bit colour depth in winNT (6.2 build 9200), 
 Display: (0, 0, 1680, 1050) - (0, 0) 
 Switching to a 1680x1050 32bit mode 
 GL Info: 4.5 - 4.5.0 NVIDIA 369.09 
 GL Vendor: NVIDIA Corporation 
 GL Renderer: GeForce 840M/PCIe/SSE2 
 GL Part ID: 840 
 GL Part EX: M/PCIe/SSE2 
 Loaded Archive: 'EnglishSpeech.big' 
 Failed to Load Archive '..\..\DATAUPDATES\UpdateEnglishSpeech.big' 
 Loaded Archive: 'Music.big' 
 Failed to Load Archive '..\..\DATAUPDATES\UpdateMusic.big' 
 SOUND -- created destination [ fdaudio ], handle [ 4 ] with [ 48 ] channels created 
 SOUND -- created destination [ fda streamer ], handle [ 5 ] with [ 8 ] channels created 
 SOUND -- created destination [ dxa streamer ], handle [ 0 ] with [ 8 ] channels created 
 SOUND -- created destination [ dxaudio ], handle [ 1 ] with [ 48 ] channels created 
 Build name: 
 Data path : C:\Program Files (x86)\Steam\steamapps\common\Homeworld\HomeworldRM\data 
 Font Load: data:UI\Font\Blender.rcf, 1680,1050 
 Font Attr: 14, Biu 
 No mapping for font 'Blender' - using 'default' 
 Resetting fp PC control word. 
 CmdLine: -moddatapath TheEcho -luatrace 
 12 Races Discovered 
 Race Filtering: DEATHMATCH rules - @Deathmatch,Extras 
 Starting Level: DATA:\LevelData\Multiplayer\DeathMatchHW2\2p_hostilities_end.level 
 Restoring video mode 
 Display: (0, 0, 100, 100) - (9, 38)

Hmm, I don’t know if I can help, here, but I do have some questions.

What type of FX is this (ballistic, special weapon, beam, etc)?

Does the game load the map and ship related to it before crashing, or does it crash during the loading screen?

Also, does this custom FX include custom or edited image files, and if so, what program was used?

It is a ballistic ‘normal’ weapon. The game crashed on the “Universe” portion of the loading screen when attempting skirmish (as usual, it seems). I edited the .tga files that were already readily available in the game using Gimp, all I did was change their Hue-Saturation and exported the files as .tga’s without RLE (RLA?) compression.

I’ve done this before with 2 other weapons and it has worked, I’m not sure what the issue is this time around

Ah. As long as you don’t try using a fork and spoon, there usually is a simple fix.

When I messed around with plasma bomb colors and the vaygr lance beam coloring, I found that if I had deleted a comma or misspelled anything, the game would give me fits, not fun. Head back to the weapon file and make sure everything is written out correctly, and work your way from the weapon file to the weapon effect files, both the ballistic and the hit effect.

If that doesn’t seem to help, try using a different race that is not involved with the custom effect, and make sure the ai is different from it as well. This will help ensure the weapon effect is the cause, and not some other accidental edit.

If you haven’t yet, can you send the fx through my FXTool?

1 Like

Went through the file paths again, there were 2 minor discrepancies, but the game is still crashing with no log of the error.

I brought in the bullet FX but it did not seem to show me anything. It indicated on the left that it found the file(s), but it wasn’t showing anything in the right view, it stayed black. When I attempted the same with the muzzle effects, it crashed.

1 Like

Can you send the files?

Sure thing, here ya go. I added in the HWRM.log and the error log from my most recent session.

https://drive.google.com/open?id=0B7jXJAcw7_odTEpncTAxQ1ZVOXM

Great, thanks. I’ll take a look at it tonight and get back to you in the morning.

1 Like

Thanks a lot!

Alright, a couple of things:

  • Can you post a screenshot of your directory structure?
  • civ1_heavy_plasma.wf (Everything in this file looks fine. You didn’t send the civ1_heavy_plasma_muzzle_flash firefx, but not having an effect that is referenced in this file won’t crash your game.)
  • civ1_heavy_plasma_muzzle.tga referenced by civ1_heavy_plasma_muzzle.anim doesn’t exist in the rar you sent (still won’t crash the game though).

The effects are playing just fine for me in my tool. Here’s the directory structure I have set up:
image

I’m thinking at this point it might be something else wrong, with either the weapon file or something else entirely different.

Oops! That was my bad, I forgot to put some of the edited files in that .rar. (I have a separate folder where I put all my files before I input them into my mod’s directory, I edited the ones in the mod directory and forgot to replace the ones in my own separate folder. I solved those 2 issues in those files :slight_smile: )

Any course of action you would suggest at the moment?

Any updates?