Help me with PhysX! (Wall of Text Ahead)

#1

Something needs to be done about the performance of PhysX in Borderlands 2/TPS and that’s what my goal is. I have spent the last 6 weeks doing a ton of research into the way PhysX works and the CPU/GPU utilization aspect of it and Ideally I would like to hire someone to work on the PhysX aspect of the game since i am not proficient in coding, and in the meantime, I am learning how to do this myself.

Specifically, I want someone to decode and edit the .dll and the .bin files in the game directory and change any calls or strings and maybe some float lines to make fluid and particle effects work better on multi threaded hardware. The end goal is for me and everyone else to finally have a fix for the low fps when PhysX is being utilized. I will be updating this thread as I come across more info.

I believe some of the .dll and .bin files in the game directory hold the code that is overriding any important INI tweaks that are made. I want to change the lifetime of particles AND SPH fluid effects since no PhysX ini tweaks work besides “MaxParticleResize”. Eventually If I come up with a tweak that fixes PhysX for me, I will release it to everyone else so our FPS can stop being held down.

Background

Back in 2013, I had a GTX 680 classified and a I7 920 @ 4.4GHz. I was able to run Borderlands 2 with no problem 60 + fps on the highest settings while on 1920 X 1080. Fast forward to now, I have a GTX 1080 Classified oc’d with a I7 5930k oc’d to 4.6ghz and I am unable to maintain that same 60fps @1920 x 1080 with better hardware while fluid and particle effects are being used. It’s most evident in, but jot limited to Bloodshot Stronghold when I am using my DP Unkempt Harold(DPUH) and fighting enemies with fluid effects around while the DPUH is kicking up solid particles. My FPS is 120 when there is no liquid or particles. I have used a lot of ini tweaks but none of the important ones work besides maxparticleresize but that does not affect the lifetime of the particles or the fluid effects.

I find it unacceptable to lower or disable PhysX as IMO it adds a lot to the game in terms of things like oh…you know…fun. I’m seeing posts all over the Web on how people with triple sli 980s, 1080s, and dual titan setups are having the same problem. Neither Gearbox or Nvidia are working on fixing this issue so I feel it’s time to do something about this and I am going to try my best to get PhysX working as it should because this is my favorite game. If this works for Borderlands 2, I will try to optimize The Pre-Sequel as well.

A lot of people who are using monitoring software are reporting very low CPU/GPU usage even when PhysX effects are intense. What is going on?

Back during release, Nvidia and Gearbox boasted that the PhysX runs great on Borderlands 2 and that we wouldn’t have the issues we at undressed having now. It’s not like it’s a month after release. The game came out 5 years ago. I think it’s safe to say we won’t be getting help from anyone at Nvidia or gearbox.

Here is a very interesting article about PhysX in Borderlands 2. It’s from PhysxInfo.com and apparently the person (Zogrim) who made the article spoke to the devs that worked on Physx and this is what he had to say.

“First thing I did after the release – I have asked the PhysX content team, who has worked with Borderlands, if game using APEX – it is not. Just default PhysX Cloth and PhysX Particle System implementations. So those settings have no use”

EDIT 1: I’m sure it’s been mentioned a few times but I want to share a link to an excellent guide on how to tweak Borderlands 2 and Borderlands TPS to look better. The guide is mostly for people that have more powerful PCs but if you know a thing or two about INI tweaking, you can set the parameters lower according to your systems capabilities. FYI, the only tweak that doesn’t work on Borderlands 2 is “Physxlevel=3” For Borderlands 2, a Physxlevel of 0 is low, 1 is medium and 2 is high. The Pre-Sequel has an extra setting of Very High. More food for thought on the subject.
[Borderlands 2 and TPS tweak guide]

EDIT 2. I figured out after playing with reshade and sweetfx that if you use the sweetfx configurator to install sweetfx with the “install sweetfx” button, it will install 2 fIles that will prevent PhysX from being loaded to your GPU properly which means that your CPU will be computing any PhysX calculations instead. Those 2 files are dxgi.dll and dxgi.fx, if you are using sweetfx, delete those 2 files in your game folder where the main executable is. They are associated with direct x 11 or 10 but borderlands 2 is direct x 9.

Apparently there is a Windows 10 compatability issue with borderlands 2. I messaged support and got the generic " borderlands 2 is not supported in Windows 10 message" reply. I gave the rep a lot of good links and info on this issue too. I expected to hear more about what is causing PhysX to slowdown.
Also I am seeing posts pointing to a specific patch/ dlc in Borderlands 2 as a cause of the poor performance however I have doubts because the same thing happens in The Pre-Sequel.

A user known as “V” on the Nvidia forums has this to say in a thread (link below) about PhysX slowdowns on high end hardware.

“I actually had a dialogue with Gearbox, the developer of this game, and Nvidia regarding PhysX issues years ago when Borderlands 2 just came out. We even made a specific tool to find issues with PhysX in the game and sent it to Nvidia for further testing. What ultimately happened was that Nvidia didn’t care enough, and Gearbox couldn’t fix it. Our short conclusion was pretty much this: This game is not well optimized for modern hardware. We had some technical reasons of course, but it’s been years and I don’t remember the specifics. I vaguely recall it being something about the cores and threads and not actually the GPU.”

EDIT 3: Just added another GTX 1080 classified so I can SLI this game because I am desperate. ■■■■ MY LIFE! It runs worse than on 1 card. I should not be surprised since this is an old game. With 1 GPU, at 3840 by 2160, I get about 50fps standing still. Now with SLI, I get 12 fps standing still. I don’t know what else to do.

For anyone interested in enabling the built in PhysX Benchmark, see my video below
and follow this steam guide

(Guajiro Pandoreño) #2

Nice post - as someone who loves the Physx in this game, I’ll be looking into this further when I get the chance (I’m off to breakfast now).

[quote=“Forkinator, post:1, topic:1558381”]Apparently there is a Windows 10 compatability issue with borderlands 2.[/quote]Did they say what this was specifically, or is this more of a disclaimer that they can’t guarantee the reliability of the game on that platform? It’s running quite well for me on 10, but I get how that could change in a moment. It’s certainly possible to run quite well on 10.

#3

I actually did some more testing today and my main post about this can be found on reddit if you are interested.

It has more updated info and I am getting a ton of hits there (over 200 pms) about whether or not i have found a solution to the problem.

I am tired of shelling out cash so i can play this game on max settings only to be let down. Borderlands2/TPS are my favorite games and I specifically upgraded my pc to be able to play them without any problems.

hmm…I unfortunately don’t have the email anymore but Gearbox said something along the lines of a compatibility issue in Borderlands 2 when installed on windows 10. I am so confused. After the hundreds of posts/threads i have read, I am seeing a lot of angles here. Lots of people saying its Physx, others saying its Windows 10. Some are saying it is just bad coding in borderlands 2.

I did more research and found that a lot of issues started after patch 1.1.3. take a look at this page and scroll down to 1.1.3 and read the last line. its pretty interesting.

(Guajiro Pandoreño) #4

I ran the benchmark: saw the frames per second dip briefly to the high fifties twice, over 120 a few times, usually around 80 if I had to estimate an average (is there a stat recorder, or should I just Youtube the entire thing with ‘stat fps’ on?) I’m running 2560x1440 resolution with G-SYNC on (so it won’t clear 165 even if it could), and Cinematic rendering. Are other people getting better or worse?

#5

I would really appreciate if the developers could chime in. This is still not fixed. I have two gtx 1080 Ti’s now and im still unable to run the game on max settings. I obviously turned off SLI for this game because i get worse fps with two cards, but that doesn’t change anything. I should have no problems running the game on max settings with one gtx 1080 Ti.

#6

This issue still needs attention.

(Funk) #7

So, back in the day I used to play Borderlands 2 with 2 x GTX 670s in SLI on Windows 7, it had issues with physx on high/medium but I was able to mostly fix those performance issues when installing the legacy physx and newest physx drivers. When upgrading to Windows 10 none of these fixes would ever work when using the same system.

Areas like the Bloodshot Stronghold are where most of the performance issues occur, especially when co-op is in play.

Over the years I have tested over and over and confirmed on many different PC configurations at home that BL2 and would have performance issues on Windows 10 that never got fixed, and now that I have a GTX 1080 Ti that runs worse even on Windows 7, and worse than the GTX 670. I hoped that Nvidia, Gearbox would fix it over those years as I’d check every now and then, especially with every Windows 10 anniversary update. Such a shame because I never played many of the DLCs because I always had performance issues even though it ran better on Windows 7 with the GTX 670 config. I didn’t even bother with TPS as I’d never finished BL2 because of the issues.

So with the announcement of the remasters I am hoping that they will have fixed these issues on newer systems that I can finally play with all the physx effects on highest without much lag and fps issues. Hopefully it isn’t just a texture update and that they update the physx system to use the latest or at least fix the issues with this update. Otherwise many who are new to the borderlands franchise who will buy the handsome collection that is on sale or even those who will revisit because of the remaster and also while waiting for BL3 will come back and again talk about the FPS issues when using Physx.

It would be such a shame if this game still had these issues.

(Guajiro Pandoreño) #8

It’s working quite well for me on Win 10. What exactly are you experiencing?

(Funk) #9

Hate having to explain myself over and over to other people on many different forums. Did you even try those heavy physx areas and blow up allot of things to cause physx to be used allot? Even tried with multiplayer as that causes more physx particles.

It’s as simple as when using Physx on High or Medium I experience frame drops that go down to as low as 35 even on my GTX 1080 Ti. Nothing changes this problem, the only thing that helped this problem was when using older hardware, and older OS(Win 7) and remembering to install the legacy physx and newer physx drivers on Win 7. Every other combination with multiple PCs give me the same performance issues/frames dropping so low when using Physx Med/High. Many people have the same problem, you can do your research around the web, but no one can give us a fix because the only people that respond are people that say it is working perfectly fine for them never having a problem in the first place. The other people that respond on other forums tell us to do things such as disable our physx and call us idiots for not doing and I find that unnaceptable. I want to play the game at it’s fullest as it should be with modern hardware/software.

I just tried the updated BL2, so utterly dissapointed, utterly utterly dissapointed. Same issues as before even with the update as I tested again. I can tell there were changes to the main exe as I saved a whole backup of all the games files to compare. Files that are related to physx, nothing changed, they are the same exact files as before.

So sad, I’ve spent so much money on upgrading hardware over the years for this game with no results. I remember even using dedicated physx GPU for the game on top of the SLI 670s, at first it was a GTX 275, then a GTX 560 Ti, then a GTX 750 Ti. Didn’t help, the GTX 275 actually worked very well for physx when using Win 7 + the installing legacy physx fix, no slow downs which is remarkable. The only reason I upgraded the physx GPUs over the years was because Nvidia didn’t support them together with newer GPUs(I stayed with GTX 670 in SLI those years).

Sad sad sad…at this point I’m just venting my dissapointment, frustrations and experiences over the years knowing that it will never be fixed, feel no hope.

(Guajiro Pandoreño) #10

Sorry man, I totally understand (really… spelling it out in detail gets tedious after several times), but the nature of the failure does help.

Everywhere I can! Sometimes I fire a corrosive Bearcat into the air and just hemorrhage ammo just to stomp around in a bunch of green rain after it’s run down off the roofs (in Sanctuary).

Here’s a good start. How long do these drops last?
If you’ve got the time, see if different PhysX bits cause the problem. I find that the liquid PhysX has no issue whatsoever. Go to the start of Caustic Caverns (where that standing water leak is), and throw some singularity grenades on it to really get the engine running and see if that causes issues. That should run just fine.

On the other end of this scale, fire a Sawbar into the distance somewhere that has a long draw distance, so the bits pop up “in front of” whatever is in the distance. Sometimes this can try to lag the engine, but sometimes not. (Note that the Caustic Caverns test above includes very short draw distances).

Also - how long are these dips into those low framerates? If they’re super brief, I might not notice them, but I think I’d notice a sustained drop to 35 FPS.

(Funk) #11

Don’t have the time to test everything, but I can tell you they are sustained ~35 FPS for as long as whatever Physx particles are moving around. For example I throw half of my grenades out in that second room in Bloodshot Stronghold. Normally liquids don’t move around as much as when they are stationary my FPS doesn’t drop as much, it’s only when they are exploded.

I hope you aren’t thinking to lower maxparticleresize as that’s the only thing that helps FPS but it basically removes Physx from occuring, especially if you lower it so much. Yes my FPS improves with it lowered. I may as well set Physx to Low if I do that but I actually want all Physx effects which a 1080 Ti should be able to do, especially if a GTX 560 Ti in SLI plus a GTX 275 was able to do all that when using Windows 7 with installed legacy physx drivers and keep a rock steady 60 FPS. The game is bugged.

(Guajiro Pandoreño) #12

I’m not… I did change the rendering engine to Cinematic, but haven’t futzed around with those other settings.

Ok - we may have something here. To confirm that it’s possible and it’s not just me unaware of a drop in frame rate here (though I’d like to think I’d notice a drop that extreme), I’ll go splash around down there when I get home (next Monday or Tuesday).

As much as I think it’s quite possible to not have a PhysX slowdown there, I am concerned that if this is the case, it will still be most difficult to divine what’s causing this on your system.

Off the cuff, I’m using Windows 10 build 1709. It updated itself to 1803 when that came out at which point I experienced serious game lag. Other players seemed to have the opposite experience (lag with 1709 but not 1803). Returning to 1709 worked for me.

I also found that (with an older video card driver version… maybe a Windows update) that Fast Boot would cause the game to be laggy maybe half the time? A reboot (not shutdown and startup but the soft restart) would correct it, which I think was because Fast Boot was trying to save the video drivers/configuration/secret sauce in memory, and reloading them like this wasn’t working.

I think these issues (including microstuttering that also seems to plague some users) are due to something in Windows, but Windows has so many variables (more than one of which appears to be able to cause this) that A) what fixes it for one person won’t necessarily fix it for another, and B) there’s a good chance that we’ll never figure it out… but we’ll give it a shot.

(So long, and thanks for all the fish!) #13

The microstutter was found to be the in-game garbage collection triggering on the tick count. You can change the setting that affects how long things remain before they disappear to adjust this.

(Guajiro Pandoreño) #14

Ah… good to know. :+1:

(Guajiro Pandoreño) #15

Throwing a sticky fire singularity grenade on the sign behind the water so it sucks all the water out of the pool and sprays it around on detonation while adding its own fire chaff particles dipped from 164 (pegged there as a G-Sync max to match my monitor) to 157. I threw a couple also while the water was flowing back into the puddle after the explosion - same frame rate.

I see a bigger drop when I open the doors and look out across that draw distance (goes to a low of around 75 and floats between this and 164, depending on the scene). My frame rate indicator is in the upper-left corner.

#16

Just want to say that I am still here and still having these issues after the remaster. I don’t know if i mentioned this in my main post, but I almost hired someone to fix the issue. Unfortunately, I did not have the money to hire him for the fix because it would take quite a few hours to do so.

He is a popular modder/app maker in the gaming scene. What a shame. This game would be flawless without the physx issues described above and I am certain it is physx along with windows 10 as i am having the exact same issues you mention

(Funk) #17

Other things to mention.

I have tried multiple gaming systems, multiple windows releases(at the moment 1809), reinstalling Windows clean always, gaming mode off and on, disabling fast boot, using bcdedit to turn on/off HPET, running Windows 7 together with my GTX 1080 Ti, deleting certain Physx files so that it uses the Physx files from the ones that are installed with the Nvidia drivers. Tried disabling power saving features in the BIOS/UEFI that would downclock or park CPU cores, and all the other things I mentioned.

The only times I had decent performance was when I was running Windows 7 + installing legacy physx + new physx(because back then Physx drivers sometimes wouldn’t be updated with the Nvidia installer) GTX 670 in SLI plus/minus a physx GPU(GTX 560 Ti or GTX 750 Ti), or my other system GTX 560 Ti SLI plus a GTX 275 again on Windows 7. I also had another system when I placed the same GPUs in there and had the same effect, working well with Windows 7 with these particular GPUs.

What I cannot answer is why when I install Windows 7 now, and use my GTX 1080 Ti, why it runs bad. Also why I am so unlucky with so many different systems, things changed, different installations, drivers, updates over the years, yet I can never manage to hit what it seems is akin to finding the needle in the haystack to get Borderlands 2/TPS running well with Physx.

One thing I can think of is I have been installing Windows 7 but using EFI boot and not the older method, but I doubt that would have any effect.

Also one other thing to mention is, back then I also ran 2x 7850s in crossfire and a GTX 275 for physx but using the driver mod that would enable physx on Nvidia GPUs when you had an AMD GPU in the same system. Than also ran quite well too. I remember having to delete certain files in Borderlands 2 to get it to work with the driver mod.

Another person on an Nvidia forum I think if I remember correctly mentioned the performance decreased, got bugged on an update with the Pirate Booty DLC.

I also wonder if the people that have great performance with Physx have CPUs that have very high single core performance, but it doesn’t answer the reason why my performance has degraded since Windows 10 and GPU upgrade(s). When Windows 10 first came out, I didn’t change anything system hardware wise. All I did was install both Windows 10 and Window 7 and could immediately see there was an issue with Windows 10, back then I put it down to being new and was hoping it would mature and eventually the issue would be fixed but now I don’t know.

(Funk) #18

When I am testing in Bloodshot Stronghold I am not looking into the distance, the distance for me would be that small room second room.

(Funk) #19

…sooo, I guess this issue will always be there for many of us. Such a shame, that every person on the steam forums just tells us the fix is to turn off physx. Sorry for the bump.

1 Like
(Guajiro Pandoreño) #20

What’s your framerate in that shot?

For me in that room before any action starts, it’s parked at around 97 looking in that direction.

When the action starts (slag Conference Call, but Maya’s throwing some Thoughtlock hate and whatnot), it ran at around 70 with two momentary dips to the 50s as the lowest rates during that fracas.