Hidden Realms Console Content Update

Hey there!

This is the third major content update for Risk of Rain 2 on consoles. With this update we are focusing on expanding the base game with fun and exciting content that the player will see right when the update lands. While Skills 2.0 had a bunch of challenges and unlocks, some players preferred to have content unlocked in the base game, and we’ve heard the feedback!

==== Major Content and Changes ====

  • Added Survivor: Acrid
  • Added 2 Stage Variants
  • Added 2 Hidden Realms
  • Added 3 Skill Variants
  • Added New Skin: Acrid Skin
  • Added New Monster: Void Reaver
  • Added New Boss: Scavenger
  • Added New Boss: Secret Boss
  • Added 9 Items and 1 Equipment to the game
  • Added Chest: Adaptive Chest
  • Added Chest: Overgrown 3D Printer
  • Added Shrine: Cleansing Pool
  • Added Drone: Emergency Drone
  • Added 3 Challenges to the game
  • Added 2 Environment Logs to the game
  • Added 6 Lore Entries to the game
  • Various performance & stability improvements
  • Various Bug Fixes

RoR_Roadmap_consoleArtifacts_1920 (1)

Thanks for dropping into this update - we hope you all enjoy everything that is new! As always, we appreciate the continued support and we have shared the updated console roadmap above so that you have an idea of what to expect with the next upcoming update.

1 Like

I love Risk of Rain 2 so much, its insane. New Borderlands 3 DLC and new patch for Risk of Rain 2 just 5 days later, gonna be a good time!

Hello i have a problem im playing on switch and the interface of the unlockables is glitched so i can’t see anything and because of that i can’t unlock acrid. I already tried multiple times to unlock him and it didn’t work i even uninstalled the game and reinstalled it but it didn’t work

Not sure if this is an oversight or if I was just too ambitious, but after the update I went and tried to unlock the Artificer and then tackle Acrid’s challenge. After failing to unlock Acrid, I also did not unlock Artificer when I went back to the menu. I’m assuming this is because I didn’t advance to the next stage instead of attempt the side challenge, but it’s kind of frustrating to have to farm up Lunar Coins again.

It’s because of the update you can’t unlock anything because the challenge tab is broken. I have the same problem

Same issues as above for Switch. Cannot see challenges, also paid for Arbiter unlock AND successfully ran Acrid unlock but got neither. Pleaasseee address and fix this.

I Love the game. But please please please fix the switch version soon. I can’t unlock anything eaither. Please and thank you