HODOR/RODOH crash on open

There’s a lot I’m not clear about with the tools, I’ll be honest. Maybe I’m not even supposed to open them directly… though I don’t really know what else to do with .exe’s. But in any case, on attempting to open either program a scripting window pops up for a fraction of a second and crashes. So my questions are two-or-three-fold:

  • Has this happened to anyone else attempting to use these tools, and if so…
  • How did you overcome the problem?

I’ve tried running as administrator and in multiple compatibility modes. I feel bad for posting this because I feel like I should be better informed before asking for help. But I have found definitive resources on the programs elusive, which brings me to the third-ish fold of my questions:

  • Can we get pinned threads about the GBX tools? There are probably already posts out there defining exactly what each tool does and how to use them. But I feel this knowledge ought to be pinned, as it is some of the most keyest of key information relating to Homeworld Modding, and so should probably be more prominent and accessible than just about anything.

Thank you to anyone who can shed some light on this (not that I won’t just thank you again when you do).

The tools aren’t crashing - these are command-line tools that take command-line parameters or scripts to drive them. There are a ton of examples of how to use them scattered around (even a UI made by one enterprising forum member) - so look around, you’ll get everything you need! :smile:

2 Likes

LOL, like I said, I’m not so privy to all this stuff. Thought the reason the scripting window was popping up (however briefly) was so I could enter said command-lines. I guess I’ll have to dig a little deeper.

The tools are made for people that understand them. They’re not for people that just mod part time. I’m afraid GBX has lost about 1/2 of the modding community.

To use a command line tool you open up a command prompt first. To do this in n modern Windows system, hit the start menu and type in CMD and pick out the Command Prompt option. You have to navigate to where the tool is on your drive, google ‘cmd navigation’ if you don’t know how and you should get several good how-tos. Then to actually use HODOR, there’s instructions in this other thread.

The information might be not quite as easy to find as is ideal, but it’s out there.

Thanks a bunch, EatThePath - I had a feeling you would be the one to bail me out! I hadn’t worked up the tenacity to go digging for the needed information yet but in retrospect the “Example Ships #1” thread should probably have seemed a logical first place to look. Beyond all of that, I’m sure glad you brought up the part about Command Prompt! I could only seem to remember the name of the Mac equivalent, “Terminal”.

In a real modern Windows OS (Win7 and later) you can just type CMD in the folder path box and the command prompt window will be set to the current folder straight up.

I prefer to use *.bat files though, as you can have the *.hodor scripts anywhere and a *.bat file can link it all up without mucking around in the CMD window. For those who might not know a simple *.txt file can be turned into a usable *.bat file just by changing the extension, so don’t worry about an editor or anything like that.

For example:

“C:\Game Files\Steam\steamapps\common\Homeworld\GBXTools\HODOR\HODOR.exe” -script="%~dp0kng_TMP_ktinga.hodor"

@echo off
rem “C:\Game Files\Steam\steamapps\common\Homeworld\GBXTools\HODOR\HODOR.exe” -script="%~dp0fed_TNG_flagship.hodor"
rem “C:\Game Files\Steam\steamapps\common\Homeworld\GBXTools\HODOR\HODOR.exe” -script="%~dp0rom_TNG_dderidex.hodor"
rem “C:\Game Files\Steam\steamapps\common\Homeworld\GBXTools\HODOR\HODOR.exe” -script="%~dp0kng_TMP_brel.hodor"

You need the *.bat file in the same folder as your *.hodor files for “%~dp0” to work (this inserts the local folder path) or you can just type in the whole path for simplicity.

@echo off” means that everything past this point isn’t displayed in the CMD window
“rem” is “remark”, essentially commenting out the following text so the CMD prompt doesn’t do anything with it

I’m sure glad I’ll have all this to refer back to in the distant future when I will have something new to make into a hod! Sure can’t guarantee I won’t have a slew more questions though! But in any case thank you for sharing! These new HOD tools have been mighty humbling… I’ve gone from feeling like a modding lay-man to a modding lay-lay-lay-lay-man.

Just keep chipping away at it, that’s how I got to where I am without any appreciable skill level :smiley: