Homeworld(1) Remastered - Hard Lock PC on startup FIXED

EDIT: Seems to be SLI related. Have disabled SLI in Nvidia Control Panel, and both remastered games work OK.

As the title says,

Getting a hard lock of my system upon launching, ctr+alt+del to get task manager up and my system freezes, causing me to have to push the reset button on my case.

Not good Gearbox…

All other games working just fine.

System specs:

i7 5960x (NOT OVERCLOCKED)
32Gb Corsair Dominator DDR4
Asus Rampage V Extreme
3x GTX 980
Asus Xonar Sound Card.
Windows 8.1 Pro

Will try some stuff to see if it’s a local issue.

You have three video cards? That may be causing the problem since I don’t think the game currently supports SLI but I could be mistaken; it’s probably your biggest bet on the reason for your crashes however.

+1 for SLI, try and disable that for the time being, also a single GTX 980 should run it maxed at any resolution (unless you have 8K) anyway. Tell us if it works!

Thanks guys,
After I posted, I went off and did a couple of things, including disabling SLI. Seems OK now, and I’ve edited the topic title and original post.

Let the shoosting commence!

Good to know, if by any chance you can also play the games without any other issues tell us: some threads here talk of little problems or downright crash hence any info about fully working copy is golden!