Homeworld 2 classic won't launch atioglxx fix doesn't work

Hello,

I’m unable to lunch homeworld 2 classic. Each time I attempt to launch the game it goes to a black screen then closes back to the desktop. I checked the error log and getting “Homeworld2.exe caused an Access Violation in module atioglxx.dll”. I’ve check online and attempted to replace the atioglxx.dll with an older version however this doesn’t fix the problem.

I have a fresh install of windows 10 and have the latest drivers for my video card and not sure where to go from here.

Operating System: Windows 10 Pro 64-bit
Processor: Intel® Core™ i7-2700K CPU @ 3.50GHz (8 CPUs), ~3.5GHz
Memory: 16384MB RAM
Card name: AMD Radeon ™ R9 Fury Series

add ‘-nopbuffer’ to your launch options.

4 Likes

I can’t belived that worked THANKS!

I can :wink: The ATI drivers don’t like the old ‘pbuffer’ systems, so just avoiding them fixes it - much better than hacked drivers. Cheers!

1 Like

This probably sounds a bit of a bone question…but where do I find these launch options?

Dean

In Steam, if you right-click on the game in your list (on the left?) - there’s a Properties option, and a ‘Set Launch Options’ button, right?