How do I play HW:R mods online?

Experimenting with some balancing mods for HW:R at the moment, and have gotten to the point where I want to test my work with a friend. I’ve configured the workshop item and got that all set up, to be friends only and everything, so we can test together.

Except when we launch the game using the “mods” part of the HW:R launcher, and select my mod, we can only play skirmish vs CPU? There does not appear to be a multiplayer option. We’re trying to play HW:R, for reference.

How are we meant to play mods with our friends? Am I missing something or is multiplayer not supported with mods?

1 Like

There is a way to do it by using command lines and moving the big file with the others. However I am not sure if this is technically allowed or not considering the multiplayer mode is still officially in beta (just like everyone else I skip the EULAs).

I’d wait for a dev/mod to reply to this thread first. By all rights we should get official support for this in the next patch if possible.

The multiplayer option may reappear once the multiplayer beta is over.

Has everyone subscribed to the mod and launched the game using the mod? All player’s must have the mod loaded to be able to join a multiplayer server.

Tried 2 methods. We both subscribed in the workshop and launched using the “Mods” part of the launcher, with the mod correctly set (verified - works using Player vs CPU). But there is no “multiplayer” option on the menu so we have no way of playing.

Also tried using the shortcut override with the -mod path set, which again, works with Player VS CPU but does also not have a “multiplayer” option. Is it a bug?

Thanks for the help, by the way.

If you are both signed up for SHiFT and you are both loading the mod when the game is started, then you should be able to create a multiplayer game and you should be able to see the server and join the lobby.

I’ll try this out today to see if this is currently broken.

It’s a bug with the launcher.

In the launcher, after selecting your MOD, you should be able to add “-mpbeta” (without the quotes) on the ‘Commandline Arguments:’ line to pass this along to the game (this argument is only needed while the multiplayer beta is still in effect). But there is a bug with the launcher where it is not appending the arguments you type into the 'Commandline Arguments:" section when it runs the game.

There’s 2 workarounds for this problem.

  1. The easiest fix for this is to right click on the game in Steam, select ‘Properties’ then 'SET LAUNCH OPTIONS…" then add “-mpbeta” (without the quotes) to the launch options. This will always be used and will interfere with things when you are trying to play the single player campaign (so you would need to remove that launch option when you want to switch back to single player). This will enable multiplayer when running the game with mods.

  2. The other workaround would be to create a shortcut to the executable in the HomeworldRM\Bin folder (HomeworldRM.exe) and then modify the shortcut to add “-mpbeta” to the end of the target line, followed by “-workshopmod”, followed by the path to your mod. This path will be different for different players. The path will start with the folder inside the HomeworldRM\DataWorkshopMods folder (that folder will by your numerical Steam ID) followed by a backslash, followed the folder with your mod’s Workshop ID, followed by a backslash, followed by the name of your mod’s .big file, like this:

-mpbeta -workshopmod 1234567890\12345\MyMod.big

You can use that shortcut to explicitly run multiplayer with your mod. Just be aware that each player will need to modify this path to use their specific SteamID as the first part of the folder name.

I’ll get the launcher fixed to use the ‘Commandline Arguments:’ text properly and in the future, you can just add “-mpbeta” in that box in the MOD section of the launcher.

EDIT: Opps, I left out the “-workshopmod” part of the commandline when using a shortcut.

1 Like

I see, makes sense. I will have to try that later. Many thanks for your support, much appreciated!