How to get past Moonshot container glitch?

(Jostabeere) #1

So I can’t play the game with my Jack now. I started TVHM, and went through Helios to the point when Jack shoot you on Elpis. My problem, after the area transfers, I end up in the container, without any interface, and stuck there forever. Restarting don’t help, I’m always stuck in this damn container, hearing Annoying Tinas passion for dicks… What do?
Edit: I can’t do anything! I’m stuck there everytime with no cutscene of the moonshot shooting me down on Elpis, and I can’t play the game with my character…

(So long, and thanks for all the fish!) #2

There was supposed to be a hotfix/update to prevent this from happening. What system are you on?

("Prepare to be Moon Shat on!") #3

Make sure that you aren’t disabling any of the games startup videos or this will happen.

(Shinri Shiogami) #4

What BeastfaB said. If you commented out the FullScreenMovie lines in WillEngine.ini on PC, then that video won’t play and you get stuck.

To get them back, verify that your .ini file has the following:

[FullScreenMovie]
bForceNoMovies=FALSE
StartupMovies=2K_logo
StartupMovies=Gearbox_logo
StartupMovies=2K_Australia_Logo
StartupMovies=NVidia
StartupMovies=Loading

In my case, I lost the above lines from my .ini file for some reason, and only once I put them back, did the game continue normally…

(Jostabeere) #5

[quote=“Shinri_Shiogami, post:4, topic:108438”]

Ye, weird, I never deleted those lines. Well, I complete deleted my Willow config foldet, that helped. Still totally stupid, that you can even do this, and block the game in that way.

(Zacharykopp) #6

“Hello! I.T have you tried turning it off and on again?” In all seriousness this happened to me a few minutes ago while playing Handsome Collection for the Xbox One (which I find strange considering this has never happened to me before. I’ve never played ultimate vault hunter mode though, so maybe that had something to do with it?). I went back to the menu several times, unequiped my oz kit, all of my items, etc l with no luck. Apparently all it takes is manually turning the console off. If you have back ground downloads on your system I recommend pulling the plug to be safe.

#7

I know this thread is old, but I had the same problem. Quitting the game and booting it back up again fixed it for me

(Sigma7Rho) #8

Still an issue, and closing and restarting the game will generally fix it, if that doesn’t work, try a full restart of your system.

(Ask me about Jack Monkey Squat!) #9

STILL an issue…my fix was to remove the -NoStartupMovies comment from the Steam launcher long enough to get past the cut-scene. Afterward, I was able to re-edit the comment into the launcher.

1 Like
(Berfest1) #10

still broken after all this time. sigh

(So long, and thanks for all the fish!) #11

I’d love to know what people are doing to trigger this bug. Trying to activate the button in the container before the dialogue finishes? Rushing the door? I’ve always been extra cautious since I heard about it and wait for the scripted actions to completely play out before even moving, and so far I haven’t been glitched out. But I’ve never seen a detailed breakdown of the circumstances under which this bug rears up its ugly head and bites.

(Ask me about Jack Monkey Squat!) #12

I hit it with Jack in both TVHM and UVHM…Real Jack loaded Dbl-Jack into the container and I exited to the surface. Jack appeared inside as normal, but the entire UI was not visible and Janey did not go into her dialogue about air and following her, etc and the door-release button would not function. Couldn’t do a thing until I exited the game and removed the ‘-nostartupmovies’ comment from the launch options in the Steam launcher. After doing that and entering the game again, I was back at the point of entering the container and being shot to the surface where things then worked as they should. But when I hit that point with my Loot Hunt Claptrap (ie - new character, NVHM) none of that happened…the scene played as it should, and with the ‘-nostartupmovies’ comment still attached to the launcher.

Help me remember here (and prepare for a probably-awkwardly-worded hypothesis) - isn’t Janey’s cut-scene with her watching the shell fly past and hit the surface removed from the T/UVHM playthroughs, and only seen in NVHM? If so, I’m wondering if the problem only happens in T/UVHM (happened to Jack, didn’t happen to Claptrap). If not, I’m wondering if the no movies comment is also skipping Janey’s cut-scene which then does not trigger her dialogue about air, follow her, etc…OR a combination of both of them. Or I’m completely wrong about all of it.

Any of that make sense?

(So long, and thanks for all the fish!) #13

Not sure about the cut-scene being in/out after NVHM, but I do have a character that could check it - they haven’t started TVHM yet (and, by strange coincidence, it’s also a Jack!). Then again I’m on XB1 so no option to skip movie intros anyway, so I don’t really know if that would help or not.

(Ask me about Jack Monkey Squat!) #14

If it’s happening on more than one platform, I may be totally wrong with my guesswork hypothesis. Do you have anything like .ini files on XB1? I’ve never owned a console (aside from a Game Boy back in the day) and have zero idea of how they’re config’d.

(So long, and thanks for all the fish!) #15

No visible files at all to the user - it’s completely closed off (even more so than on 360, and much more so than PS3/4). I’ve never thought to actually check whether the moonshot container bug was specific to one platform before now. I’ll have to dig back through the tech support sections and see if there are any clues on that.

Update: @Ossie - confirmed that the video sequence showing the container being shot out of the cannon, Janey watching it, etc. is skipped on TVHM on XB1. After hitting the travel button and loading into Serenity’s Waste it goes straight to the fade-into=conciousness and the dialogue about lack of oxygen, then the button gets green highlighting and you’re out.

I’m guessing that the game has it’s own way of skipping the cut-scenes when running in other than NVHM, and that this also ensures that the mission script is set to the correct point. As a side note, I know that there are some odd glitches in BL2 only if you have the same flag enabled on PC.

1 Like
(Ask me about Jack Monkey Squat!) #16

Which are those? I have the no movies comment on the BL2 launcher also, but haven’t seen anything weird that I’m aware of.

(So long, and thanks for all the fish!) #17

I forget the specific details, but there’s a bunch of missing audio, and at least one mission can get a little odd as a result.

(Ask me about Jack Monkey Squat!) #18

Huh…I hadn’t noticed anything like those, but I’ve had the comment stuck on the launcher for some time and I may not have been aware of them. I’m gonna remove it (it’s not that hard to esc thru them) and see what happens next time.

But now that I think about it, I have noticed a few minor dialogue curiosities in TPS at times…wonder if the comment on that launcher is the cause. Gonna edit it out as well, just in case.

(Live25) #19

Remove your Oz kit prior to leaving Helios.