HW Launcher crashes instantly

Starting yesterday, for no obvious reason, the HWRM launcher has started crashing instantly when I try to start it.

I have not taken any system updates (Win7). HWRM has not updated (I have the most recent version from August). I have not added any mods nor am running any mods at launch (I have been playing with the official balance mod but have not changed anything in the way I was using it from when it worked previously). I have not updated or changed any drivers. The issue does not resolve with a reboot and persists even after deleting local content for the game and re-downloading through Steam. The local game files pass verification through Steam.

Once in a while the launcher screen will appear momentarily before the crash occurs, although never long enough for me to interact with it.

I had played a half-dozen multiplayer games successfully the previous few days with zero issues so this was a pretty strange surprise.

Error message:

Problem signature:
Problem Event Name: APPCRASH
Application Name: Launcher.exe_Homeworld:Remastered launcher
Application Version: 1.0.0.0
Application Timestamp: 55d4c53d
Fault Module Name: clr.dll
Fault Module Version: 4.6.81.0
Fault Module Timestamp: 5584e56f
Exception Code: c0000005
Exception Offset: 0000b2f8
OS Version: 6.1.7601.2.1.0.768.3
Locale ID: 1033
Additional Information 1: d212
Additional Information 2: d21234eaa477a388cd56129fc2c847cf
Additional Information 3: 3c75
Additional Information 4: 3c75cc3dabbe9a069d51798bdb0bca9e

Read our privacy statement online:
http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
C:\Windows\system32\en-US\erofflps.txt

EDIT: in my most recent attempt to launch, a new error window has popped up before crashing - this has happened a couple times now when trying to launch but is inconsistent:

Launcher.exe - Bad Image

C:\Windows\System32\MF.dll is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or software vendor for support.

Are you able to launch the game just using a desktop shortcut with the - mpbeta switch?

Long overdue update:

Eventually got things working again. A bad system shutdown corrupted some deep core system .dll files - I had to go through and replace them all by hand, and reinstall .NET frameworks and a few other things. The game is working again like it’s supposed to.