HW Remastered doesn't start at all

I’m trying to start remastered version through launcher, nothing happens, game doesn’t even start and if i’m trying to launch through .exe file, i get 0xc000007b error. Got everything reinstalled, drivers, physx, .net, vc redistributables, nothing works :frowning:
My specs are AMD A8-5600K, 8gb 1600 Mghz, geforce 650 Ti Boost.
Any help would be appreciated.

Is there an errorlog.txt in the games executable folder?

If so specifically what module is the fault caused in?

Nope, there’s no errorlog.txt, i guess it’s because the game never really starts.

I’m trying to start HomeworldRM.exe, if that’s what you’re asking.

Where exactly do you get that error? Does the launcher or game .exe not ctd?

No don’t worry if there is an errorlog.txt the very first line will read something along the lines of HomeworldRM.exe caused an access violation in module debug.dll before the CPU register states and memory contents.

You might check in the HWLauncher folder for the launcher error log, assuming it actually crashes. What happens exactly, be specific; I click on ‘Homeworld Remastered’ button, wait for 2 seconds, then crash / error / nothing etc…

I don’t think I can help with your problem other than to say I have seen an awful lot of AMD A8-xxxx users having trouble with this game, and it would be nice to find a solution.

One thing you might try is running the launcher.exe as admin, and the same for the HomeworldRM.exe, though if you run the game from its executable you will need to append console commands to make it load the campaign properly etc.

Another thing you might look at is renaming the Gearbox logo animation video, as some users have reported that it causes a crash for them, alternatively tap the escape key directly after selecting the game from the launcher to see if it might skip it.

One more thing; if your system is a laptop? you may have integrated graphics as well. If this is the case check in nVidia control panel and setup the game exe profile to use the nVidia card on high performance.

Best of luck, I hope your problem is solved soon.

Well I start up launcher, hitting “Homeworld Remastered” then launcer dissapeares, and after about 5 seconds, steam tells me i’m not playing. If i run HomeworldRM.exe i just get 0xc000007b error without any launching at all. My MB doesnt have any integrated video :frowning:

I think the most likely thing is a realtime protection component of your antivirus is blocking the program before it starts.

What Antivirus do you have?

1 Like

well, actually, i dont have any

You are running Windows, right? It tends to freak out if you don’t have an antivirus. At the very least you will be getting warnings every time you turn it on. Before going any further, I strongly advise installing Malwarebytes AntiMalware (free version) from their website and running a full system scan.

https://www.malwarebytes.org/mwb-download/

i have re-installed my system about a week ago and it’s running fine except Homeworld.

Capymah, I am assuming that you are running windows 8 because otherwise you would have warnings about Antivirus. If this is the case, the built in Windows Defender is not very robust and you may have picked up any number of malicious programs that can interfere with the install and running of sensitive programs like Homeworld Remastered first release. Please run a full scan with Malwarebytes to eliminate this possibility. If not;

I found this thread here:

http://www.tomshardware.co.uk/forum/43092-63-application-unable-start-correctly-0xc000007b

The solution in there is to go to C:\Windows\SysWOW64\ locate the “msvcp110.dll” file. DO NOT DELETE IT AS THEY SAY IN THE LINKED THREAD. Instead, rename it as “msvcp110.bak” so we can reverse the change if it does not work.

Then download a new version of that file from here:

http://www.dll-files.com/dllindex/dll-files.shtml?msvcp110

Choosing the ‘Manual Fix’ make sure you get the correct version for your system (64 bit or 32 bit) then extract the zip file and place the new .dll into your SysWOW64 folder. There are 2 versions for each system listed there, so perhaps download both and you can try each in turn.

When you have placed the new .dll in your system folder try to run the game again, first from the launcher then from the .exe.

I installed software you recommended and it hadn’t found out any malware on my rig.

dll-dancing haven’t helped too.
Appreciate all your help! getting kinda desperate though =(

Hmmm. No change at all?

I had a thought that the game might be using the System32 library instead.
Last things to try on that note are:

  1. Do the same thing with the msvcp110.dll in System32 folder. Probably use the 32 bit versions though.

  2. Rename the files in both folders but don’t put any replacement in to see if running the program creates them.

  3. Put back the originals afterwards.

  4. update .NET Framework 4 here: http://www.microsoft.com/en-us/download/confirmation.aspx?id=17718

  5. update .NET Framework 4.5.2 here: http://www.microsoft.com/en-us/download/details.aspx?id=42642

Other than that check again for …ErrorLog.txt in the game executable folder, and scan the thread I linked before at Toms Hardware, there are a few more ideas there. Would be nice to solve this, but don’t worry too much there is the possibility that a bug in the launcher / exe is only present on your particular system components, and Gearbox will be able to test it with your information to reproduce the error.

Tried everything. Game still doesn’t work. Even after the update.
Is there any chance for moneyback?

capymah - the issue you are having relates to improper/incorrect VisualC redist files - and shouldn’t be unique to this game, as these are very important files for many games and applications.

Generally you should install the correct redist files - and in this case there seems to be a pretty nasty mis-match. It really shouldn’t be too hard to get this right and have you rolling.

PM me if you want to set up a time to Skype or take a call - and I’ll do what I can to walk you through your setup and get right files in place.

Problem is, i nearly did everything that can be done with these “incorrect visualcpp redist files”, i deleted all of them, reinstalled them, i even reinstalled Windows today, just to see, if it works on clean OS. Well, nothing has helped me so far.

Reinstalled windows, that’s harsh. I really thought that would have helped it mind. Talking of VC++ Redists, I can give you a list of what’s installed on mine, you could compare them in control panel ‘uninstall programs’ list and see if you have a mismatch.

Microsoft Visual C++ 2005 Redist. : 4.84MB version 8.0.61001
Microsoft Visual C++ 2005 Redist. : 2.78MB version 8.0.56336
Microsoft Visual C++ 2005 Redist. : 4.28MB version 8.0.59193
Microsoft Visual C++ 2005 Redist. (x64) : 6.83MB version 8.0.61000
Microsoft Visual C++ 2008 Redist. - x64 9.0.30729.17 : 12.4MB version 9.0.30729
Microsoft Visual C++ 2008 Redist. - x64 9.0.30729.4148 : 12.3MB version 9.0.30729.4148
Microsoft Visual C++ 2008 Redist. - x64 9.0.30729.6161 : 13.2MB version 9.0.30729.6161
Microsoft Visual C++ 2008 Redist. - x86 9.0.21022 : 5.95MB version 9.0.21022
Microsoft Visual C++ 2008 Redist. - x86 9.0.30729.17 : 9.63MB version 9.0.30729.17
Microsoft Visual C++ 2008 Redist. - x86 9.0.30729.4148 : 9.54MB version 9.0.30729.4148
Microsoft Visual C++ 2008 Redist. - x86 9.0.30729.6161 : 10.1MB version 9.0.30729.6161
Microsoft Visual C++ 2010 x64 Redist. 10.0.40219 : 13.8MB version 10.0.40219
Microsoft Visual C++ 2010 x86 Redist. 10.0.40219 : 11.1MB version 10.0.40219
Microsoft Visual C++ 2012 Redist. (x64) 11.0.30501 : 20.5MB version 11.0.30501.0
Microsoft Visual C++ 2012 Redist. (x86) 11.0.30501 : 17.3MB version 11.0.30501.0
Microsoft Visual C++ 2013 Redist. (x64) 12.0.30501 : 20.5MB version 12.0.30501.0
Microsoft Visual C++ 2013 Redist. (x86) 12.0.30501 : 17.1MB version 12.0.30501.0

Note all versions have both 32/64bit installs. I have no idea of the specifics for this game, though I expect fro 2010 onwards. @BitVenom, doesn’t the game install dependencies on the first run? Pretty sure I remember seeing that steam information box ‘Step 1 of 1 installing VC++ redist etc.’

Sam, thank you a lot. I had to find some of these redist on the net, but now i can at least launch the game. Thanks for all your help. Though i really don’t understand, why is it so hard to include all the necessary software in some folder or even after game installation. Not the Net installer, but every single redist, so people like me wouldn’t have to search through google to find them.

Oh, excellent :smile:

No problem at all, really glad you got it running. I am pretty sure the game does install its dependencies on the first run, at least on mine the first time I booted it through steam an information box popped up ‘installing Microsoft VC++ xxxx’ (which it quickly skips because I have all the relevant ones I guess) but errors can occur, a little power flicker, or a cosmic ray hits your CPU just at the wrong moment and turns a 1 into a 0 …

It happens but it can be very tricky to sort out from an end user point of view.

1 Like

I know this is necroing an old thread, but I just downloaded the game today and ran into similar issues, so I thought I would follow up in case anyone else runs into this.

I found this post and then looked at the readme.txt file I found in the %steamlibrary%\steamapps\common\Homeworld\HomeworldRM folder that indicates that the software requires Microsoft .NET 4 Framework and Microsoft Visual C++ Redistributables (2012).

Seeing that, and assuming that maybe I had the wrong C++ redistirbutable format, I did a quick Google search for C++ redistributable and came up with the following page that allowed me to download the software:
https://www.microsoft.com/en-us/download/details.aspx?id=30679

Once I downloaded both the 32 and 64 bit versions, I ran each one. It indicated that it was already installed but did give an option to repair the installation. Repairing both the 32 and 64 bit versions now has the game working correctly on my computer.

2 Likes