HWR Patch Bugs and Issues


#166

That would be nice. And I bet it is able to be modded in. Maybe somebody can give it a try sometime.


(Snake_B5) #167

Which UI settings do you mean ?


Hiding the RU meter (in no-HUD mode) is easy :

Open finalbuild.lua (in data\ui\newui\build) and replace
onHide = "UI_HideScreen(\"BuildInfo\"); UI_SubtitleWide()",
with
onHide = "UI_HideScreen(\"BuildInfo\"); UI_SubtitleWide(); if UI_IsScreenActive('NewTaskbar') == 0 then UI_HideScreen('ResourceMenu') end",

Open research.lua (in data\ui\newui\research) and replace
onHide = "UI_HideScreen(\"ResearchInfo\"); UI_SubtitleWide()",
with
onHide = "UI_HideScreen(\"ResearchInfo\"); UI_SubtitleWide(); if UI_IsScreenActive('NewTaskbar') == 0 then UI_HideScreen('ResourceMenu') end",


The UI toggle is doable, but need some modifications in the option menu and some specific code somewhere else. I can do it, but I won’t give a timing, because I’m fairly busy at the moment with some other UI works I should have delivered a long time ago ^^


(Delicieuxz) #168

Hi Dwarfinator. Glad to hear that the RU issue is fixable.

The UI settings that I mean should be preserved is that, when a person sets the UI into disabled mode (except for when opening build menus), then that setting should be remembered by the game when build menus are closed again. But, there’s a little glitch, where the RU meter doesn’t disappear again when the build menus are closed, after they were opened. So, I just mean this:

This is what currently happens when opening and closing a build menu:

  1. new game is started, RU meter and HUD are on the screen
  2. player presses [Backspace] 4x to make HUD disappear
  3. no UI is on the screen
  4. press [B] to open the build menu
  5. build menu opens, and RU meter is visible
  6. press [B] to close the build menu
  7. build menu disappears, but RU meter stays on the screen
  8. to make the RU meter disappear, player must press [Backspace] 4x after closing every build menu
  9. next level starts and HUD is fully visible again, despite being disabled at the end of the previous level, and the player must press [Backspace 4x] as the first thing they do in the game, and 4x again each time they open and close a menu

This is what the situation should be:

  1. no UI is on the screen because player has set no-HUD as the default configuration in the options menu
  2. press [B] to open the build menu
  3. build menu opens, and RU meter is visible
  4. press [B] to close the build menu
  5. build menu disappears, along with the RU meter. There is once again no visible HUD on the screen
  6. next level starts with still no visible HUD, because no-HUD is still the default setting in the options menu, and is how the player last configured it

Another setting that would be great to have added to the in-game settings menu is the no lens-flare fix that BitVenom posted earlier.


(Snake_B5) #169

ok, I see no problem here, if the toggle is implemented in the option menu.
Concerning the RU meter problem, you can already resolve it with the fix in my previous post :slight_smile:

I can’t do anything about the lens flare parameter. It’s a command-line thing, not something which can be changed in-game unfortunately.


(Delicieuxz) #170

I thought I’d give this a try today, though looking in the Homeworld Remastered folder on Steam, I don’t see the directory paths that you indicate: “Open finalbuild.lua (in data\ui\newui\build)”

Here’s what I see:

I can’t find finalbuild.lua anywhere. The path you mentioned seems to apply, according to a web-search, to the non Remastered Homeworld 2. I’m guess finalbuild.lua is the same, and that the needed strings to be changed might be contained in a differently-named file, in HWR.


(Snake_B5) #171

you need to unpack Homeworld2.big first, with a tool like XUnpack for example.


(Delicieuxz) #172

OK. I see what to do, though, the program keeps crashing (I tried 5 times), while outputting the message in this screenshot:

Is there an alternate program I can do this with?


(Delicieuxz) #173

Hi BitVenom,

If the fix for the RU meter not closing in no-HUD mode when the build / research menus are closed is as easy as Dwarfinator has shown, could it be added to the next HW:R patch?


#174

You might want to make a separate post with this ‘bug’ just to follow the format of reporting game issues.

Also, there are no needed third party tools to extract .big files anymore for Homeworld Remastered. I personally just use the windows command prompt and the Gearbox Workshop tool ever since the last major update. I’m fairly certain there is a tutorial here for extracting big files somewhere on this forum, though I might be wrong. Someone correct me if I’m wrong here.


(Delicieuxz) #175

I’m not sure I understand what the format for reporting a bug is, but I think I’ve presented the full synopsis of the no-HUD / RU-meter issue in this post.

And I agree with what you said:

[quote]I personally would rather it show with the rest of the ui and hide when prompted. I understand why it pops up with the menus, as it is helpful. The launch menu doesn’t cause the same display prompting, which I though was interesting.

It would be great to have a dedicated ‘on/off’ toggle for ui entirely, in which only the build and research toggle key would show and hide their windows with the ru counter. Hopefully a patch can fix this.[/quote]

I might eventually look into extracting the .big file another way, so thanks for mentioning the cmd method, though it’s certainly nicer if the no-HUD mode works natively.


(Delicieuxz) #176

Today I played the Raiders Retreat extra mission, and after completing the objective, a radio voice said I could jump to hyperspace when ready. However, the hyperspace jump button didn’t appear on the screen, and pressing ‘J’ didn’t initiate hyperspace. I couldn’t find way to trigger the hyperspace jump to finalize the mission and get the achievement, so I saved the game, quit, and re-loaded it. After that, the hyperspace jump button appeared, and I was able to finish the mission and get the achievement for it.

Also, likewise with needing to reset the HUD each new game, to set it to no-HUD mode, the same issue is present regarding pressing ‘TAB’ to cycle through ship highlights, to disable them, each new game. The setting isn’t remembered between games. Maybe, there could be a HUD section in the settings menu, to configure the default HUD setup?


(Xercodo) #177

My first guess is that it’s crashing because ti can’t write something somwqwhere because it doesnt have permissions. Try running in admin mode to see if that helps? At what point EXACTLY does it crash?


(Delicieuxz) #178

My account is the only account on my PC, and has full Administrator privileges.
It crashes almost immediately after pressing the Extract button.


(Herbyguitar) #179

That means crapp. Windows will usurp you at every opportunity…


(REARM V2) #180

I found an animation bug. The infiltrator pod clamps flip rapidly during animation:


(El Rizzo) #181

I also found a bug with shadow casting in the game. If a ship casts a shadow on another object and you zoom in/move the camera a bit past the shadow casting ship, the shadow it casts disappears.@BitVenom As far as I remember you worked on the lighting, correct ? Is this an engine limitation or not supposed to happen ?

On the upper screen I was just past the ship casting the lower shadow on the mothership, once I zoomed in a bit more it disappeared as can be seen below.