I can't download the game in Steam


(Meodp17) #1

I’ve already tried restarting and refreshing Steam, but I can’t download any of the files. The open beta folder remains empty, the file verification says nothing, and the game says it’s at 0/0 bytes.


(Not actually Jesus Christ) #2

Have you had the same problem with any game before? Also are there anymore games in the download queue?


(Influencer Guy) #3

The game files should all be there and this is the first report of it I’ve seen. Any other details you can give me?


(Tom213tom) #4

ive have the same problem however mine says missing executable and then it check the file folder and its empty


(Meodp17) #5

This is the first Steam game I’ve tried to download/play. I never was able to do the preload either, it kept saying the preload was suspended. I tried again today since the beta went live I figured there would be a direct download instead of a preload.


(Influencer Guy) #6

This is a known issue from earlier today that has since been fixed. Restarting Steam should force an update and get the exe file into the game for you.


(Tom213tom) #7

ive restarted steam and my pc several times


(Meodp17) #8

This is what normally shows up when I try to download a game.


This is what shows up when I try BattleBorn.

I literally download nothing when I click on this.


(Tom213tom) #9

this is what happens when i click download


then it just does this


(Influencer Guy) #10

Interesting. I’m going to loop in @sssmg to see if he has anything to add to here. Any thoughts Scott?


(Meodp17) #11

Anything?


#12

Just wanted to jump in and add that I’m getting the same thing. I go to the Battleborn store page, click the “click here to start playing!” text, the cursor changes to the loading circle, then nothing. No download or install window appears, nothing gets added to my Downloads in the Library.


(RoninOni) #13

Same here.

4:17pm PDT (PST+1)

Closed and restarted steam.

Launched steam with admin rights.

Click the “click here to start playing” as well as the graphic at the bottom that says “Click Here To Download Now” on it and it just goes to spinning circle, then nothing. EDIT: Steam non-responsive during spinning circle.

I’m guessing servers overwhelmed and temporarily shut down, but confirming +1 with same problem and no proposed solutions so far have worked


(Kunkiddo) #14

Same problem. Won’t download and steam is not responding far around 10 seconds after i click the "click here to start playing! " thing.


(RoninOni) #15

several steam restarts and reattempts later and it worked.

went through nothing at all but spinning circle, bunch of steam updates on a restart, ‘searching for steam updates’ on another attempt (didn’t find anything, restarted anyways), incomplete install prompt that trying to returns ‘cannot install’, and finally complete prompt that leading to download.

My guess is Steam’s services are a bit overwhelemed at the moment (since it took a couple steam restarts to even get my 7 minor game updates)

This is why preloading is a thing :smiley:


(Meodp17) #16

Yeah, well I tried to preload and it wouldn’t let me. All it said was preload suspended and 0/0 bytes/bits/whateveritwas.


(Toastkings Tk) #17

I’m in the same boat. I click “Click here to download now” and it fails to open the download.


#18

Three Steam restarts, one computer restart, still the same thing.


(Kunkiddo) #19

Now it works…somehow…


#20

Finally. You just have to keep trying. I don’t think restarting the Steam client or your computer actually does anything except give the servers a chance to catch up with the requests. Either way, a fail on Gearbox’s or Valve’s part (or maybe both) for not adequately preparing for this much demand.