I can't download the game in Steam


(Meodp17) #21

Still nothing for me.


(5050Clown) #22

_ was able to download the pre-load, however now steam shows this _

and then the below when clicked

  • i have beta participation turned on, everything updated, have restarted steam + machine a few times. Help appreciated!

(5050Clown) #23

Other additional info screens:

And:


(Muttogamer) #24

Was also getting a loading circle cursor and steam going unresponsive when trying to download the client. Reboots seemed ineffective.

Just gotta keep trying I guess…it seemed to slowly glitch itself into working. got a couple of odd steam error menus to pop up and with enough spamming, I got the normal install prompt.


(5050Clown) #25

kept restarting steam, then let it sit for a bit. another game download appeared, completed, and now BB is updating. Odd but working so far.


(Meodp17) #26

Still nothing downloaded. Any other ways to download the Beta on pc?
As of 2:06 AM UTC: AAAARRRGGH


(Cyborgdragon354) #27

Well I downloaded the game on steam first and then it didn’t want to open at all so I tried on my Xbox one and it installed but it crashes every 5 mins of loading


(Meodp17) #28

I am now fairly annoyed. So, does anybody recommend Team Fortress 2; I’m kind of curious on whether to play it or not.


(Jaidon Dean) #29

I FOUND THE SOLUTION!

  1. Just go to Steam on your browser
  2. Log in
  3. Go to the Battleborn store page
  4. Click “click here to start playing!”
  5. When the browser (ideally Chrome) asks to ‘Launch Application’, choose it
  6. Chrome will launch Steam unless its already open
  7. Finally, you will be prompted to download the Open Beta of Battleborn!

Your Welcome In Advance,
Jaidon


(Meodp17) #30

I am not a moron. When I am prompted to download the game it says I need 0/0 files, and when I verify it it comes out correct, because I do indeed have the 0/0 files.


(Os3HifDEJaGMbZdc) #31

i can download it but around the 20mins mark it says download corrupt its just this game that i have this problem


(Jaidon Dean) #32

I restarted both Steam multiple times and my computer once before it started working.

Try going to the Steam folder and delete Battleborn from your ‘common’ in your File Explorer. Then it might be a fresh download.


(Os3HifDEJaGMbZdc) #33

there is no battleborn folder in my steam folder tho.


(Meodp17) #34

That doesn’t work for me, my download isn’t corrupt, it’s just telling me I need to download 0 files. Which finishes in a minute and gives me a completely empty battleborn folder.
Also, has anybody successfully downloaded the game, without preloading?


(Meodp17) #36

I’d ask for someone to upload a copy of their steam backup, but I have a feeling that it’s against their TOS …


#37

I’m having the same issue described here; what gives, any mod support on this yet?


(Meodp17) #38

Bump, 'cuz y not.


#39

I too am still waiting for something constructive.


(Rakan2000) #40

same problem i really want to play someone help


(Minus12) #41

I’m having a problem very similar to this.
Download comes to 88% (6.7 GB out of 7.6) and then download rate drops to 0.
I’ve tried deleting the entry from Steam and downloading it again, same thing – 88% and 6.7 GB out of 7.6