I cant play with my friend!

So, my friend and I have been trying whole day to play Borderlands2 together, but everytime I try to connect to them, or anybody, it says: “Connection failed”. My networ speed isn’t the fastest, but it doesn’t make a problem for all the other games I have, and we chat in party with no problem. Is anyone having the same problem and does somebody a solution, or they will be patching it? Let me know please

1 Like

Having the same problem - see my post. Same deal, though at one point he seemed to fix it by resetting his router to factor settings and doing a fresh install of the game. But then he took a two hour break, came back and it hasn’t worked since. He can’t get online at all, though we can chat in party??

1 Like

Where in the world are you based? My friend is in Tunbridge Wells, England.

1 Like

I live in Bulgaria. In a town called Sevlievo

1 Like

Alright - let’s hope gearbox fix it. You can add me on PSN if you like and we can keep in touch on this. If we get a fix I’ll let you know, and maybe you could do the same? PSN: GumboGong

1 Like

I’ve submited a ticket to gearbox support, let’s hope they answer soon!
Adding you right away!

1 Like

You’re the only other person I’ve seen online mentioning this problem, but I assume there are more. See you online.

1 Like

Have you had a response from Gearbox yet?

1 Like

I have the same issues here in Canada, I can rarely get online mode working, I have a ticket submitted and haven’t heard anything for 8 days :frowning:

1 Like

Do you mind adding me on PSN and letting me know if you get this resolved?

1 Like

Same issue here, and I have a solid 127MB connection and have opened all relevant ports on my router. Please let us know if you learn of a fix.

1 Like

I am also having this issue. I have opened all ports, put my PS4 in DMZ and refresh my router countless times. I can only select LAN and Offline as my Network Options, Submitted a ticket 6 days ago, still no reply. Do GB even give a damn about this problem?

1 Like

See my thread ‘connection failed error’ there is a fix suggested there.

chamone835h
Hi mate I’ve found a fix that worked for me, but you might not gonna like it (depending on your Internet connection speed). I believe it was maybe due to a bad install. I deleted the game and reinstalled it (had to redownload the updates too). Once this completed (wait for updates to install too!), I put the ps4 into safe mode and rebuilt the database (takes 5 minutes), this is basically a defrag of your hdd and you should do it every now and then anyway to keep your system running smoothly. I then started up the game and boom! my characters were all there and I could connect no problem. This method is fine if you own the disc, but if you own the digital copy it could take ages to download the game again.
Hopefully this is a permanent fix, but I will update if I find out it’s only temporary.

chamone831h
What I did was completely reinstall and wait for updates etc. Then rebuilt the database BEFORE starting the application (don’t know if this matters, but that’s what I did haha). While database was being rebuilt i also unplugged the router from the wall for like ten minutes so it was nice and cold and then voila, all was working. In addition to usual ports needing opened, apparently the game needs an additional one (7777 I think- but don’t quote me, check this on the forums). Do this before turning off router so it’s all fresh and has the best chance of working. Best of luck

1 Like

Latest from my friend with same problem (as of Sun 5 April):

This is more of a workaround than a fix.
The steps. Shambolic though they are.

Tried reinstalling the game and rebuilding database. No success.
Tried Power Cycling my modem and router. Turn off both. Boot up modem then router when modem fully booted. No success.
Whilst in game at main menu went to Network in Ps4 settings and ran Setup Internet Connection. SUCCESS.
Would have to repeat Setup Internet Connection each time I restarted the Game after shutting down the Ps4. But might have to run the Setup few times before it would connect. Sometimes it would work at Main Menu sometimes in a Map in game.
Game would go back Offline when saving and quitting to Main Menu.

This morning. Nothing was happening again.
Rebuilt database. No Success.
Power Cycled modem and router. No success.
Repeatedly ran Ps4 Setup Internet Connection, at Main Menu and in Game, until SUCCESS it connected again.

1 Like