I cant travel to gehenna....the planet is not on the sanctuary list!

hi…im having this issue…does anybody out there got same problem?
im running Borderlands 3 super de luxe version on pc and dlc1 and dlc2 works fine but not the dlc3 which i have found it on sanctuary desk in front of the change machine and i can see it on my next mission but i cant find the planet when im going for it…
any idea how to resolve this problem?
sorry if my english is not that good thats because im italian living in italy:-)

You have to fly the ship there first. When you go to the bridge, it should be in that list when you activate the console keyboard.

If it’s not there, restart the game??

its 1 week about im restarting the game everyday and the planet is not on the list…all the other planets are there but not the new dlc3.
i looked for the wanted poster—highlighted with a yellow exclamation mark—on the table in front of the Quick Change station on Sanctuary III and found it but not the planet in the console keyboard…

You have to first select the poster and accept the mission. Then go to the bridge and fly the ship. If your poster still has an exclamation point above it, then you haven’t yet accepted the mission.

2 Likes

I had a similar problem getting to the DLC2 planet at first.

I play on Epic Games pc platform and what I had to do was:

  1. Access Epic games library
  2. Select the 3 horizontal dots at the right side of the game’s title
  3. Select “Verify”
  4. Let the verification process complete
  5. Redownload the DLC files
  6. Restart the game

This fixed my issue and I hope it is helpful for you as well.

2 Likes

Yes, that’s what you have to do.

The DLC is not installed automatically and you have to select it.


Ho avuto lo stesso problema, davo per scontato lo avrebbe installato automaticamente una volta rilasciato.
Invece ho dovuto selezionarlo e installarlo manualmente come spiegato da tuck7216

yes guys…i did it:-)
thanks a lot for the info/help…
what i did was:

  1. Access Epic games library
  2. Select the 3 horizontal dots at the right side of the game’s title
  3. Select “Verify”
  4. Let the verification process complete
  5. Redownload the DLC files
    and now im waiting for the installation and than restart the game.
    again thanks for your help tuck7216
    grazie x l’aiuto
6 Likes

infact…the dlc2 it self-selected and self-downloaded and i tought the dlc3 was going to be the same and i was waiting and waiting and waiting…but now thanks to tuck7216 and your info its all going good.

1 Like

AWESOME!

Remember to wear you cowboy hat for +10% extra “pizazz”
:nerd_face:

1 Like

I had to go into settings and apply the download.
Still not working.

I had the same issue, i fixed it by going to my game library and selected “manage add ons” from there i re-downloaded the DLC and it seems to have worked