I don't know what's wrong

I posted this abit ago, and while a fellow Vault Hunter tried to help, it didn’t yeild any fruit. So I’m hoping this post will, well, help, as I love Borderlands too much to not play it.

None of my DLCs for the first BL will work. I’ve installed them, over and over again. I’ve cleared my system cache about four times. I’ll deleted every trace of Borderlands 1 on my Xbox, hoping it would fix the problem, but it won’t. No matter how much I install the DLCs, the actual game won’t recognize them. The menu at the main menu telling me they’re available won’t show and I can’t fast travel to them straight away in Fyrestone (as I should be able to despite not powering the fast travel network). I can’t find anyone else with this issue and I don’t wanna play a game without the DLCs. Anyone help? :frowning:

  • Triple pack disc, Xbox 360, both the DLC disc and main game disc are fine.

What do you see if you search the dlc from the xbox marketplace, do they show as installed ? It is strange indeed and it’s the first time I heard about this. I will look into this tonight, good luck in the meantime !

Did you enter a support ticket?

1 Like

I posted in your other thread as well - finish “skags at the gate” and they should show up.

The Marketplace says I don’t have ‘em installed. Ugh. I’m restartin’ Borderlands as I type this, hopefully it’ll work.

Everything is working now. :slight_smile: Tech support helped. Thanks for the help, guys. I wish you all legendaries in your travels. Cx


What was the final fix for this? (Since it’s possible someone else may run into the same issue.)

Do you have the instructions to fix this issue? Ive been trying to get this to work for days now and there’s no active threads I could find besides this one.

Okay, this is gonna make me sound like a handsome jackass… and I sorta wasted others time. But it never worked because I didn’t do the mission right.
I mean, the first two times were because they got corrupted. But every other time was because I never actually left Fyrestone. I always assumed once I save Ned, I could start them… completely forgot you need to EXIT Fyrestone. I’m SO SORRY.