I just cant start the game

Hello,

Whatever I tried, I just cant play
I just cant launch the game and get to the main menu

While I m using DX11, the game crash after AMD logo
While I m using DX12, the game crash while claptrap keep running (take some times)

I NEVER went to the main menu…

I did update my nvidia drivers twice since the launch
The game is up to date
I did already verified the files, and even reinstalled from 0
I tried some “tips” as launch as admin

Nothing work
First game ever I m stuck as this

nvidia 1070 inside, noway it cant handle this one, as every other game are working fine here

First: you’re not alone, several posts about not being able to launch.

Now, have you installed all windows patches / updates, if not try? Have you run DXDiag?

Oh and while your GPU might be ok, what specific CPU & how much RAM?

Hello,

Windows is up to date :slight_smile:

16Gb Ram
Intel i7 7700k

I didnt run dxdiag before, what I should look for with it ?
No problems found in notes part of it

I have never played the game yet either. I bought it on launch day and still no help from the developers. Having the same problems as you.

Don’t know, on one of my 2k support tickets they asked for it… sorry :frowning: