Inventory and Trading Problem

PROBLEM. In co-op, my partner (cousin) loses keep/junk markers on his backpack items. When he goes to trade at a machine, he is only shown equipped items.

BACKGROUND. We started BL2 a few weeks ago, with no problems. Two sessions ago, my cousin found he was unable to mark gear in his backpack. We thought it was a temporary glitch and continued but shortly after we lost connection. After restarting everything was fine. In the session before last, he had the same mark up problem. This time we restarted straight away, assuming it indicated a connection problem. Again it was fine.

In our last session the same thing happened yet again but restarting didn’t correct it. We thought we’d carry on, anyway, but when he went to sell up, the vending machine only showed equipped gear. This happened on all sort types.

ATTEMPTED RESOLUTION. We tried a number of restarts, including restarting Steam. My cousin validated his installation. One file needed re-acquiring but nothing changed in game. He uninstalled & reinstalled the game. This time he tried the game in single player and everything was fine. He joined my game and the problem returned. Out of interest, I joined his game and he had no problem.

TECHNICAL STUFF. He has an “office” desktop, which probably rates medium-to-low spec for gaming. I have quite a high-end desktop, which is why I usually host. We both have fast, reliable broadband. We have recently played all the content of BL(1) GOTY Enhanced with no special problems. We have been playing BL2 for a number of weeks without this problem occurring.

I’ve played thousands of hours of BL2, solo and in co-op, and have never come across this before. Has anyone here seen it and is there a solution? Any help would be greatly appreciated. Thank you.