Inventory FPS drops suddenly

#1

Hi I’ve been playing the game for a month, even streaming it a bit and everything worked fine. However for 2-3 days now I can’t open my inventory without going from a stable 60FPS to a stable 4FPS for some reason. The problem also occurs when pressing escape.

I know other players have that kind of problem but usually they drop to 15-25 fps and it happens in shops and during intense fights for them. It’s not the case for me, shops, sanctuary’s safe, customization stations and fight work totally fine.

Now here’s what I already tried:
-reinstalling the game
-switching the disk it’s on
-launching it with Nvidia settings or integrated settings
-unplugging everything that was plugged to the PC
-disconnecting from steam and internet
-tweaking settings from the lowest to the highest with or without Vsync
And maybe other dumb things.

It might seem like a little problem however for streaming it is not acceptable to lose that much time in menus and it even makes it hard for everything like quitting the game since at 4 fps most inputs aren’t even registered and I have to press inputs many times before it works. Now just imagine farming for a weapon with that problem that is not something I can work with.

Since it worked fine for a bit more than a months I don’t think the specs are responsible for that.

If you have an idea or had the problem yourself please save me ^^ !

Thank you if you took the time to read that and sorry if there is english mistakes here and there.

(How much time do we have?) #2

How many items do you have in your inventory, and are you playing with or without the enhanced 4K/UHD textures enabled?

#3

Hello and first of all thanks for the quick reply.
I have all slots equipped with an item and have only 3 items in the backpack.
I did install the texture enhance pack to see if it would do anything for my problem and I don’t see any difference.

(How much time do we have?) #4

I was thinking if anything having it active might explain the problem, since all the items displayed in your inventory are rendered in real time using the game engine and 3D models.

There are a number of threads in this section dealing with sudden - and in some cases extreme - FPS drops, although I think yours is the first to highlight this issue while in the inventory. That said, some of those threads may prove offer additional trouble-shooting ideas. A common one seems to be finding the right combination of video driver and Windows update version, or using the Windows compatibility mode.

You don’t mention what streaming software you are using, but that might be useful info for some of the PC regulars here to know (along with Windows and graphics card/driver versions).

Not much else I can suggest, but @Derch, @Jefe, @Adabiviak and some of the others may have some ideas. You can also file a support ticket - the support desk staff may have something in their knowledge base that could help; they will need more specific information about your set up though.

(Where's lucky?) #5

If the backpak or bank isn’t overstuffed, unless your PC barley meets performance criteria I don’t know

#6

I haven’t explored that kind of solution yet (tweaking the video driver and windows update version) however I don’t think I had to perform any update recently so it’s weird that it would have appeared so suddenly I’ll try searching this way though.

I was using OBS to stream on twitch.

The bank has 2 items in but I’ll try throwing everything away anyway just to be sure it isn’t one item causing it all.

And I basically know nothing in terms of PC parts but mine is less than a year old and can run recent games such as Assassin’s creed in high settings without any trouble. And is it possible that it would’ve worked for more than a month if my PC didn’t meet the criteria?

I didn’t pay much attention at the time but I remember noticing a little hiccup when selecting my character when the problem appeared, like a microfreeze that didn’t happen before. Well that’s thekind of reflexion I’m getting at ^^

(How much time do we have?) #7

It’s certainly possible that something happened to your save file, although normally a corrupted save wouldn’t even load. Can you start a second character (without streaming) and run them through to Liar’s Berg, just to see if the problem affects them too?

1 Like
#8

I did creat a new character and the problem is still there. I did find another iteration of the drop when the notifications appears to tell me that I have unlock a new skin and other bonuses.

I checked on a previous charcter I had and same thing.

Also I did not mention it previously but I own the Brderlands 2 Game of the year edition.

(How much time do we have?) #9

What start-up options are you using on the game? If notifications are causing it, that’s curious but may be related to your game settings. When you open your inventory, the game will also update the stats on the BAR page as well as your mission log progress - if something is interfering with those processes, that might explain the FPS drops.

#10

Well sorry to ask that but the translation might not be obvious to me: what are “start-up” options?

I do not activate bonuses from the BAR page and do not use any ranks, can the accumulation cause the lag?

Oh and I also tried plugging the pc to an external screen via HDMI, nothing new.

(How much time do we have?) #11

Since you don’t know about them, I’m going to guess that you haven’t set anything odd in them! Basically, there are game configuration options beyond those you can access through the in-game menus that you can change either by adding launch options or by editing the games config file.

#12

Oh no I didn’t get there ^^ however I just found a new thing.

I was checking for CPU and Memory usage, when outside any menu it is about 60% usage for both but when in a menu the CPU usage drops to 10-20% and Memory usage remains unchanged which might be a normal thing but I don’t know anything about that.

Then that’s where something happenned I’ve put the game in windowed mode and low res so I can check other windows at the same time. When the game window is selected the game works at 4FPS but when i select another windows the game runs smoothly at 60 FPS in the menu (I can tell by the animation of the blue highlight on the item currently hovered) until I select the game window again and it goes back to 4 FPS.

(How much time do we have?) #13

Something about that is ringing a bell with other FPS issues in BL2 (and other games in the franchise).

Edit:

Second post - is that the mode you’re running in? I know in some other threads about FPS drops, changing the display mode (windowed, fullscreen, etc) did indeed have an impact. Also, you might want to double-check your OBS settings against those shown further down the thread even though the issue there was capturing the video. Overlays are another potential source of FPS drops!

Edit 2: https://forums.gearboxsoftware.com/search?q=FPS%20drops%20category%3A113

#14

Yes I do use “Fullscreen windowed” in game and use the “Capture a specific window” in OBS.

I did open OBS to see what it did and it is so frustrating to see the game run smoothly through the visualisation of OBS when I select that window but go back to 4FPS when selecting the game window.

Edit: I already went through other topics but didn’t find solutions that where convincing regarding my problem. I did find another way to make the FPS drop happen: when using alt+tab to make the steam overlay appear the game goes slow motion as well as the steam overlay wich is basically unusable at this frame rate.

#15

Well I think I’ll wait for Borderlands 3 then, hopping it will work better ^^.

I’m just going to try to send that support ticket. I tried to but I’m not sure if the ticket has been sent correctly, any chance I can check if it worked? Do I have to be logged in to the Gearbox website to send one?

(How much time do we have?) #16

You should get an automated reply by e-mail with a ticket number fairly quickly (probably sooner); you may want to check your spam folder if you don’t see anything in a couple of hours. A human response may take a bit longer.

It sounds like something in your video pipeline is causing problems, but quite what is a good question. You may want to pop open the task manager to see if anything else is running in the background that might be causing a bottle neck.

You didn’t mention this, but you may also want to check what the CPU and core usage on your machine is while playing normally versus inside the inventory - there has to be a clue somewhere, since lots of people do have the game running on modern hardware. Unfortunately, the edge cases are the hardest ones to diagnose!

#17

I did mention in a previous message the percentages of memory and cpu usage but I don’t know a lot about it maybe the numbers would be more meaningful, I’ll see when I get back home.

Edit: When outside any menu the CPU is at 70% total with 60% going to borderlands 2.
Memory usage is at 65%

When in a menu it drops to 10-12% for cpu total with 4% going to borderlands memory remains the same.

When I select another window and the game runs fine in a menu the CPU numbers goes back to when I’m not in a menu.

I’ve manually stopped any task with more than 1% of usage except for the game.

(Guajiro Pandoreño) #18

I’ve never heard of a slowdown (especially that slow) for an inventory check, but frankly never looked at framerates during that event. From 164FPS, swapping to inventory dips to a low of 84 and then climbs back for me; definitely a dip, but not single digits.

Are you playing with the enhanced texture pack? Not that this is necessarily responsible, but I think this event dropping so many FPS would have hit the radar before if it was a systemic thing?

#19

Thank you for your reply. As I said at the beginning of the topic I did install the enhanced texture pack but after the problem appeared. I wanted to check if this would have an effect on it and it doesn’t at all.

It feels weird that it is so consistent, I can do whatever I want it remains at 4FPS. And the CPU dropping to almost no usage, it’s like the game goes to sleep or to energy saving mode everytime a menu is open.

#20

Ok, yesterday I used the task manager to manually shut down anything I could shut down.

So today I turn my PC on and I got a windows update, not sure if there’s a link between the two (closing everything and the windows update). And uppon openning steam I also got a steam update, again I don’t know if there’s a relation between any of what I did.

But the result is a fully working inventory… Sorry for the time loss and thanks to everyone who replied.
I’m trying to check if everything works and I will come back if I find anything new.

2 Likes