Inviting friend to multiplayer game stopped working a month ago and we have tried everything to fix


(InNOut) #1

Well not everything but many things.

We love the game (BL2) but are now super frustrated that we cant play together. My buddy and I have been playing through co-op but about a month ago we started getting “please check network cables” whenever I try to add him to my game or he tries to add me. The specific reproduction steps are:

  1. Logon to PS4 and enter BL2
  2. See friend in main menu
  3. Invite to game
  4. Says connecting
  5. Error message: ‘Please check your network cables’
  6. Player that tried to connect gets locked out of network mode (when you try to switch network mode to public or to any other non local mode it save updating session but doesnt actually change anything) until you return to game selection screen and enter BL2 again. Host player is unaffected.

Can also be reproduced if 1 person is in game as single player but open to friends, and the other player just tries to join game.
What is odd is that we can usually join other multiplayer games, just not if he or I host. Both of our PS4 network tests come up ok. We have even tried things like:

  • dropping our MTU in PS4 network settings
  • using completely different connection to PS4 (local wifi, tether to phone, back to wired)
  • port forwarding on routers
  • reseting the PS
  • etc, etc

Any other suggestions will be welcomed. tia


(Not a real Dr. but I got style...) #2

Never had the issue or especially knowledgeable on the matter but 2 things that come to mind.

  1. If you have the game on your HDD. You could try to delete and reinstall. Should get rid of cache issues. I think.
  2. Did you tried to create/join a party together? Maybe an error message there could hint you where the problem is.

PS4 BL2 GBX Forum Members Community
(InNOut) #3

Thx @Dr_Do-Little – I was actually just about to delete from the PS and reinstall to see if that made a difference when the v6.0 PS update came out. We both installed that and we have connected for first time in month or two.

Not sure if it was one thing or a number of things but its working!


(Not a real Dr. but I got style...) #4

Glad to see your issue been solved. Installing a new sys version is a pretty good reset! :slight_smile:


(Vault Hunter, Guide, Forum Dad) #5

It probably cleared all cached game data on restart. Question: in normal use, do you fully power off your PS4 between sessions, or do you leave it on or in quick-start mode?


(InNOut) #6

Its a mix but more rest mode vs complete power off. Thx again for the assist :slight_smile:


(InNOut) #7

:+1: for sure


(Honorary Miscreant & Charlatan) #8

I sincerely doubt this. I’d say it’s more they stopped supporting the game once THC released because it wasn’t released as a labour of love, but as a cash cow. I love these games and Gearbox but let’s call a spade a spade. It wouldn’t take them much effort to identify such a simple issue if they really wanted to, the fact is they don’t want to at this point.


PS4 BL2 GBX Forum Members Community
(Vault Hunter, Guide, Forum Dad) #9

They continued supporting the game with hotfixes and updates through to Jan. 2016. But the connection issue had been happening since the HC launched in March 2015. Those updates included fixes for some connection issues, but clearly there must be at least one other cause.

Bottom line: if it HAD been a simple issue, it would have been fixed. And I know for a fact that they worked hard to try and identify the cause because I was one of the folks over on the XB1 posting information about when we encountered issues to try and help them narrow down the cause.