Is there a problem with part 2 of the Claptrap dlc?

I downloaded the compatability patch then part 1 , and then part 2. Everything prompted me to install the relative file except the part 2. I also see that in the downloadable content, that part 2 is “purchased”, but not downloaded even after downloading twice. I’m on xb 360. Anyone have this problem?

May not unlock until around 1:00 pm today … maybe … I really don’t know.

I did get the Shift acceptance form on one machine after 11:00pm CST or so last night.

So parts seem to activating at different times.

I managed to get part 2 to install, but now I get a window popup that states I need to download another patch??? I don’t see another patch. I have the compatability patch downloaded and installed.

I can play no problem on XBox 360

Fellow 360 player here: how much room will I need for the Claptrap DLC? My drive is rather full, and I’d like to know if I need to move things off to storage.

First part of the DLC is 2.05gb, and the second part is somewhere around 440mb.

Thanks. Apparently, I’ll need to clean up a bit before I hit the download tonight…

Seems I got mine to work now. I just deleted the patch and redownloaded it. Alls well.

I’m having the same issue. Downloaded the 2GB part and it says I don’t have it yet I can clearly see it on my hard drive. Just deleted and re-downloaded (I think), gonna try again??

Same problem download the 2 parts dlc and says that i have to update to the latest version of the game, i have redownload, clean chache and still get the message, can any 1 help plz??

also having same problem

STILL F***ING having this problem and it’s my fourth download… why pay for something I can’t use! Wish there was a number to call or something

Same problem here. Both files are named upgrade 2 in the in the downloadable content menu of the game for me, I sincerely hope this isn’t anything to do with why it is not working because that would be an extra super stupidly infuriating reason

On your hard drive it says specifically which is 1 and which is 2, but in-game you can just look at the file size.

Add-on: I tried starting the game without signing into Xbox Live, and when I went to hit “Continue”, a blank screen came up before it started on the Menu Screen and just said A or B down bottom… not sure if this has anything to do with it.

Add-On 2: Now it says that it downloaded (in yellow on DLC Menu screen), but I need the latest title update to do it… Going to try to delete title update from hard drive and see if it works.
Nevermind… there is no title update on my hard drive…

3: Now my DLC Menu has gone back to red text saying “Not Downloaded” yet again… I give up, about to break my disc in half then put it in grinder.

I’m on X360 - I have downloaded the 2 parts and compatibility pack. Part 1 and Compatibility pack is installed. Part 2 says not downloaded even though i did this twice (after deleting and trying again).

You can still play the DLC, however, just go to the fast travel station and select Deck 13.5 and fast travel there.

Unfortunately it still had the star next to it and didn’t work… HOWEVER it does now!! No clue what happened though… was running through UVHM again and all of a sudden I realized I was getting more experience! When i loaded it, the DLC still said Downloaded in yellow but I can play it now.

Did you completely exit the game after downloading both parts? I was still getting the “You need an updated patch” message after getting both even when I backed out of the game menu to the start screen and returned, but completely exiting the game and restarting fixed that.

On 360. I’ve also redownloaded both parts, rebooted, deleted them, tried again and the game is only seeing part 2 as downloaded. Still unable to play.

Yeah I had that problem for almost 12 hours yesterday. I honestly don’t know what fixed it! I tried re-downloading it after deleting and clearing cache, I downloaded it 7 times yesterday!! ha I gave up, and finally started playing normal UVHM when I realized that my experience bar was going up!!

Same problem for me. I would download part 1 and part 2 for part 2 to only be recognized. I deleted part 1 and downloaded it again 2 more times. It’s like it recognizes it as “downloaded” but not at the same time. I cut the Xbox off and tried again later and then mysteriously, part 1 was recognized as “installed”. I downloaded part 2 again and it worked fine. Today, part 1 isn’t even recognized as “installed” anymore. What’s up with that?