Issues with Refresh Rate (Borderlands Enhanced)

For some reason, when setting certain settings through the Video menu in game, they refuse to stay and revert to what they were prior. Two notable ones are Anisotropic Filtering and my Resolution + Refresh Rate.

Anisotropic Filtering continually reverts from 16x or whatever setting i set it to to Trilinear, and while my resolution will change to what i set it to, it repeatedly defaults to 23Hz no matter what resolution and refresh rate combination i set it to… Unfortunately, this refresh rate issue seems to be causing screen lag as well. Im not dropping frames, but I’m definitely not showing the frame rate Im getting because as soon as I drop a single frame or two, youd think my frame rate was in the 20s, not the 60s

I’m less concerned about the filtering and more concerned about my refresh rate since its messing with the frames im seeing. I’ve tried setting it to different settings and it keeps reverting. I’ve verified my refresh rate for my primary display (set to 60). I’ve verified my refresh rate from my NVIDIA control panel (also showing 60). I don’t think it’s an issue with my video card as the system has no problems automatically detecting it (I’ve got a 1060). The game REFUSES to recognize a refresh rate other than 23Hz for me. I don’t have this problem with setting my refresh rate in any of my other games.

Any ideas?

i am having the same problem. Seems to be an issue that is widespread.

Hey im playing and loving bl1 again thanks to the enhanced edition .
I cant seem to be able to run it in 60hz on my tv tho ? When i set it to 60hz it Reverts back to 23hz all the time ? Any fix for this ?
It seems to be running in Windowed mode too everytime i restart the game.

Merged threads.

Check that the game is using your GPU (there’s a couple of threads here where that is described as being a problem).

I’ve also seen some posts about the display mode being relevant. I’ll see if I can find that…

Edit: A few bits and pieces here, although the immediate problem is different.

Thanks it said its using my gpu when i started it for the first time .
The game also said that my computer didnt meet the minimum requirements ? Im using a 3770k mildly overclocked and a 980 ? Should be enough ?

How do you change the selected GPU?

1 Like

This fixed it for me :

Went to Display – Graphics Settings – Browse —

C:\Program Files (x86)\Steam\steamapps\common\BorderlandsGOTYEnhanced\Binaries\Win64

Select the BorderlandsGOTY application (41000kb - should be obvious)

Options – select High Performance.

Prior to this the game was unplayable.
I just had a friend report the same results.
Thanks for the tip @VaultHunter101


huge thanks to @Jefe and @VaultHunter101 for this GPU fix. this was also plaguing my experience. now its so beautiful. smooth, unlimited frame rate. high def, its just mind blowing compared to what it used to be under my old graphics settings. this has been an entire new experience. knowing this info, i’ve done it to all the borderlands apps from steam. so now, any of them i play will look at least this good. so I’m stoked. thank you thank you. :innocent:

1 Like

How do I check if the game is using my GPU? Regardless, I think it must be, because I’m playing at 4k on the highest settings. Also, I’m one of the people posting about how my issue was with the display mode. I discovered that if I switched it from borderless window to fullscreen that it worked fine without any issues. I think it’s a different problem than the other people are having in this thread.

See @Jefe’s post up a couple ^^. There should also be monitoring apps which can report your CPU and GPU load, but now I’m way out of my depth; hopefully one of the PC-gurus can point you in the right direction.

1 Like

I also switched to borderless window at that one person’s recommendation but it was my above post that fixed it. Once I did that I was able to go to max resolution and basically max game settings and had no issues - including co-op. I kept the borderless window however (just because it was more convenient for me).

Found this slightly easier fix

Unfortunately, not the cause for me. I’ve only got the one GPU detected no matter what application. Something to do with my BIOS where if on boot it detects I’ve got a GPU in my first motherboard slot, it disables the onboard graphics. I did go through the steps though and verify that the game is indeed using my graphics card. As for the other recommendation I try Borderless windowed, I’ve had it in borderless windowed and it still hasnt worked.

Actually you can monitor your CPU and GPU % Utilization (load) in Task Manager in Windows 10. I actually do know a few good third party applications to do the trick as well. I’d be one of those PC-gurus but unfortunately this issue seems to be running circles around me.

Yeah I’m having the same issue with the refresh rate except mine defaults to 50hz. I have a 144hz monitor and I can tell that the framerate isn’t right. Is there no fix for this, or will gearbox have to patch it to fix this? Gotta say it’s quite annoying. I also tried the above fixes with no help to the problem with the refresh rate resetting.

@VaultHunter101 @Jefe

Yeah, that fixed it completely for me. Thanks!

1 Like

Great - I’m kind of keeping tabs on this : do you have a laptop or desktop? So far it’s been laptops only.

Who? Me? I have a desktop. 1080ti graphics card.

OK - thanks - there goes my theory.

LOL. You got it working for a lot of people. That’s good enough for me :slight_smile:

Desktop as well… i5-7600K and NVIDIA GTX 1060. One of my buddies got the free upgrade as well (we’ve made it our mission to run through all the Borderlands games before 3 comes out) and he’s suffering from the refresh rate issue as well. Instead of his being locked to 23Hz like mine though, his is locking to 50.

I’ve seen reports from people all across the internet having the same issue where their refresh rate is stuck on either 23 or 50. I wonder what causes the difference?

I am having the same issue except im locked at 23hz for a 60hz monitor. I did try changing the options to high performance on my game like it says above, but that didnt make any difference for me. I also cant display frame rate with nividia. Any ideas?

1 Like