KB Integrations disappeared on Logitech G Pro

I pre-ordered BL3. As soon as it came out I set up a custom profile in the Logitech G HUB. I discovered to my delight that the game supports (supported?) some kicka** lighting integrations. Fast forward a couple of weeks. An official Borderlands 3 Profile is released for G HUB users. However, while my keybindings and stuff worked fine, the lighting integrations are gone. I’ve searched high and low through G Hub and haven’t found a way to restart the integration support. Ideas?

I was able to tie the integration to the official Borderlands 3 profile by doing the following:

  1. Navigate to C:\Users<your_username>\AppData\Local\LGHUB\integrations_config\ (one of these folders contain the integration for Borderlands 3)
  2. Go through each of the folders (mine was in the folder titled a7463f78117ff7d3) and review each config.json for “name”: “Borderlands 3” (line 30)
  3. Once you find the right config.json, take note of the “supportedApplicationIds”.
  4. Navigate to C:\Users<your_username>\AppData\Local\LGHUB and open the settings.json.
  5. Press Ctrl + f and search for Borderlands.
  6. Find the “applicationId” that matches the “supportedApplicationIds” which was noted earlier. This ID corresponds to the custom app that was added.
  7. Search for:
    “applicationFolder”: “C:\Program Files\Epic Games\Borderlands3\” and you’ll come across the official version with its own “applicationId”.
  8. Take note of the “applicationId” and go back to the config.json from earlier.
  9. Replace the two “supportedApplicationIds” with the one that was noted from the official version.
  10. Quit G HUB and save the config.json.
  11. Relaunch G HUB and it should now be tied with the integration (the custom app will no longer have the integration).
1 Like

First, thank you for such a well laid out, in depth tutorial for how to fix this issue. I appreciate it. Second, I’m sorry to report that going through the steps doesn’t seemed to have helped. I followed the steps exactly, and GHUB is still prioritizing custom lighting over game controlled lighting. I did double check to make sure I have the “Allow games & applications to control illumination” checked.

1 Like

In G HUB click the profile under ACTIVE PROFILE. Under Games & Applications click on BORDERLANDS 3. You should see a section for INTEGRATIONS:

If you click on this, it should say Borderlands 3 with the option to disable it. Click the integration for the option to enable it:

image

Hopefully this helps.

EDIT: Deleted previous post in light of new info

UPDATE: Yeah, I fail at IT. I did a system reboot for a update for a different program. Full keyboard integration has been restored. Thank you so much for your help.

2 Likes

No prob. Glad you were able to get it to work.

Thanks @Nextbeat – I just installed from Steam and had it on my non-main drive (D:), so this guide helped me get it to work with the official profile.