Latch paths not working

I’m having real trouble with latch paths. I had a single path working with no Link or ClearRes then added a second one, so then they both didn’t work. I tried linking them and adding ClearRes, but it still doesn’t work. Then I went back to my single path and unlinked it, but it no longer works!

The Hgn_Carrier example has multiple latch paths with no Link or ClearRes flags, the Kus_SupportFrigate has multiple paths with Link and ClearRes flags. The game seems very sensative to small changes that break the path for no apparent reason. Sometimes my collectors refuse to use the path if the carrier is moving. Sometimes they get stuck in the latched position or the queue and will only get unstuck if the carrier starts moving.

Does anyone have any insight into this?

I’ve found the following tends to give me the least trouble with paths:

  1. If you have a LATCH path pair it with a LATCH EXIT path only, even if you also have another EXIT path
  2. Don’t link paths. Just don’t
  3. For entry paths have your start position and the second point of the path within each other’s tolerance sphere to help the AI realise that it can use the path, really, it’s not a trick
1 Like

Thanks, that’s helping, but they still will not unlatch when the carrier is moving. In fact, it seems that they are not fully latching, they just sit there full of resources until the carrier stops. Then they latch and unlatch as normal.

Sounds like the combination between speed and tolerance are too restrictive on the last point.