Let's compile a list of all STILL present bugs, shall we?

Amara expedite skill is not working

1 Like

My main gripes as of this moment are the slaughters. All of them have issues with enemies getting stuck in the maps which makes it unplayable. By that i mean slaughterstar enemies not jumping off the top platform, getting stuck in walls,and of course the joke that is red and blues loot falling off maps. Know how hard it is to farm lucians calls? Also cistern enemies just dont come out of their tunnels making it unplayable. Slaughtershaft is the least bugged one but even in that you get the occasional enemy in wall or tinks getting stuck in floors when they go in for turret deployment. All i ask is fix these slaughters after a year and a half please. Im on PS4.

1 Like

The mantis cannon will permanently be out when I play COOP and enter a new area. When I actually shoot it, a new one will appear and overlap the one that’s already there. Even if I unequip it, the animation wont go away. Only solution at that point is save and quit.

Not sure if this happens solo, but it ALWAYS occurs on COOP for me.

Oh it happens solo too.

Honestly when I started this topic I didn’t think it was this bad ; DDDDD

4 Likes

I’ve had the mantis cannon stop working–I don’t know if it’s from spamming too much or what but often it will no longer deploy. The only fixes are save/quit or unequip the cannon as an action skill then re-equip it.

1 Like

Normally from spamming too fast (or too much) but since last patch mine will sometimes freeze on first shot which sucks when dropping in on a boss.

Find it easier to unequip/reequip rather than restart but it really interrupts the flow and if playing coop has led to some untimely deaths.

1 Like
  1. Vehicle Customization slots increase to 5 from default 3 and the first 3 slots with the Outrunners don’t save any changes.

  2. Area Discovery percentage is broken, going beyond 100% as it counts more Crew Challenges than there actually are, Crew Challenge meter is also different between the one on the list and the tab.

  3. In some locations map borders extend to areas that are outside the boundaries (Ambermire and Devil’s Razor) and thus can’t be explored, made blue.

  4. If you hover over a Fast Travel Station’s icon or over its tile on the Map, then you don’t get a tooltip for any other objects on the Map, like the Vending Machines and Quests until you close the screen and back up again.

  5. I’ve found during Slaughterstar 3000/Maliwan Takedown that Flash Troopers bug out when they drop to 1% hp sometimes, instead of running off and exploding they become invincible.

  6. Weapon reticles get oversized when opening vending machines until you bring up the ECHO device and back down again.

  7. Gehenna doesn’t show planetary regions like all the other planets do.

3 Likes

Oh it is just some people would prefer not to see the bad in things and just focus on the good, which is fine but you have to be honest about it as well. @GBX on the other hand…well they just prefer to keep their heads buried in the proverbial sand.

1 Like

Another stupid thing in Gehenna is you cannot set a waypoint in Ashfall Peaks.

Daily challenge (on xbox) “Kill Broodmother”… only she still doesn’t spawn.

Bor Sci machine boosters vanishing when transitioning maps… sometimes

I just remembered that the Legend of McSmugger quest is still bugged as well

How? Did it 3 or 4 times so far and never had an issue (Xbox)

another bug;: after killing GenIVIV I keep falling through the floor and have to save/quit (if playing as Zane and the clone is active I’ve been able to swap back at times–but still annoying as hell).

On the 3rd Mysteriouslier mission, Beef Pissikenn skips his dialogue and his loot room won’t open. because of this Claptrap doesn’t open the door and you can’t move on to find Francis’ head. this is a serious bug and needs attention immediately. I’m stuck in this room and can’t move to the next part of the mission, which just so happens to be the last part.

1 Like

Oh here’s a good one:

So apparently Victory Rush in practice… doesn’t actually work O_O

4 Likes

The victory rush being broken is just hilarious, it’s been one of the most used artifacts as it was mostly good for the prefixes that could be on it and then after all this time it turns out to do nothing

4 Likes

OMG I agree with this. It’s not technically a bug, but so damn annoying. Just give me a way to interact with the wall on sanctuary to turn it off. I’m not buying the DLC just to kill this dialogue, thanks.

4 Likes

I’m still unable to complete the final mission from Bounty of Blood, so frustrating! I just want to do the final fight. Even more annoying to pay for DLC that doesn’t allow completion.

1 Like

I’m tired of hearing this audio sample. “…but what were you thinkin!? I know they tried to kill you and all, but it IS what they were designed to do ! …”

Freddie in Handsome Jackpot says it. The problem is he keeps saying it later in the DLC. He says it almost every time you load up a map in that DLC.

3 Likes