Low fps on high end rig

Hey there. I am running the game on a 2080ti with i9 9900k but i am still hitting fps all the way down at 45. I have tried with ultra and very low settings, but it does not affect the fps. I have my fps unlocked. Please help… this makes the game extremely unplayable…

  1. update drivers
  2. switch to DX12 (first load is like 3-4 minutes)
  3. remove background c***ware
  4. be sure to have at least 16GB of RAM free.

Report back with more info.
I have ancient potato CPU (with recent GPU) and game is playable.

1 Like

All drivers are up to date, switching tu dx12 gives stuttering every few seconds and i spent my entire budget on gpu and cpu, so my total ram in the pc is 16gb XD.
and remove waht ware?

1 Like

the game also used to be playable for me, barely ever dopping under 80fps. But i recently had to do a full reinstall of windows due to some software errors giving me freezes

This is odd. I’ve never did a “full reinstall”. I had windows 7 for 7 yrs (now Win10). I would test hardware with prime95 / furmark to check if everything is stable as it should be.

Furmark was averaging at 206 fps in 1080p, currently running the prime95 benchmark. will update as soon as complete. After i will try and run 3d mark and compare to earlier results

hmm… i think something might be wrong with my cpu overclock. I ran into a bluescreen with prime 95 and 3Dmark scored a full 1000 points lower than last time. Mainly beeing the cpu score that is pulling down

jup… CPU was ‘‘AI overclocked’’ wich aparently is ■■■■… it was overclocked to 4.5ghz with way to low voltage. Got a smooth 5ghz overclock running now without any bluescreens during testing

Fixing the OC did not fix the fps problems… Its only occuring in BL3 though

And what about “default” settings for all components? It might be wrong PCI-E/whatever ratio creating unexpected behaviour under constat high load.

i have tried with full default in OC and in bios but that only worsens the performance. I have tried putting up a hardware monitor while playing, and i am on a constant 50-60% load on cpu, ram and gpu. Even under fps drops the load is not affected…

Have you checked the power allocation for the game?

Nvidia control panel allows it to be set on a game by game basis and that would effect the max load the gpu can take on.

what settings exactly? I have looked up some guides on how to maximize performance (powercontrol most of it) and set it all to favor performance

The nvidia one I was thinking of is under the nvidia control panel

Manage 3d Settings -> Program Settings -> Borderlands 3 -> Power Management Mode.

If your running it on your main SSD make sure you have 10gig free

Open up Nvidia control panel set the optional settings to performance not quality

Go to game set to high over all then customise the following:

go to game turn off ambient occlusion
reduce shadows, reflections and fog to medium, foliage

DX 12 offers some benefits but also for some reason doesn’t seem to like some gear combinations so try this on both DX11 and 12

let me know and I will screen shot some of my settings, only running a 1070, I7 hexcore 32gig ram, but at 1440x2556 still getting between 67 and 120fps

I checked the Nvidia settings and they where all by standart on prefer performance.
I am running the game from my secondary ssd with more than 500gb of free space. And as I stated earlier, adjusting in game settings does not affect the fps. Setting everything to the lowest settings gives me like 5fps more

I wonder what is creating such problems. It might be task migration between cores (and some cores do not share L3 cache) ? I want to understand why on ancient CPU game is working quite ok (60-70fps with some dips from time to time). My suspiction is that meta-code or whatever code executed in denuvo (which might be dynamic form of VM) might behave differently due to unknown variables (like different instruction set available etc…). This is why this should be removed ASAP.

On second monitor I have task manager opened / with gpu-z to see when dips are showing up (mostly its related to SSD activity). But nothing remotely like OP described.

How can I check th L3 cache?

I have noticed that it is happening depending on in-game area. Worst is on eden 6 at Jacobs estate in the very beginning of the map. I just don’t understand why I did not have this problem before the re install… I might just try and delete windows and reinstall manually instead of using the reinstall option in the OS.

hey there. i also had lots of frame dips and stuttering. i updated my windows 10 version to the newes one. normaly after a reinstallation you have the newest version active, but if not, do a update. it solved most of my problems. running a mid class rig, ryzen 5, 16gig ram, radeon rx 580. and volumetric fog ingame eats up performance. i also locked my fps with vsync at 60 fps. it feels way better and is overall more constant. good luck

my entire system is up to date, The OS, driver for cpu,gpu and ram, drivers for peripherals. Everything… So that cant be the issue either… i think i might just delete my os and do a clean install as if it was never on my ssd in the first place instead of reinstalling using the windows feature