Low FPS with a decent rig

Hello,

I’ve got a decent rig, but I’ve got low FPS in BL2 only (tried with just one other game, Shadow of Mordor, and got no problems). On the main screen, I’ve got 72 FPS (in-game capped), but once I play, I barely reach 50 FPS.

Here are my detailed components :

  • MB : Asus M5A97 R2.0
  • CPU : AMD FX-8320 Black Edition @4.4 GHz
  • Cooler : Be Quiet! Dark Rock 3
  • GPU : Asus GeForce GTX 970 Strix @1.4 GHz
  • RAM : 2 x 4 Go Corsair Vengeance DDR3 @2.1 GHz
  • HDD : Seagate Barracuda 7200 rpm
  • PSU : Cooler Master G650M 650W

I tried :

  • without PhysX,
  • with PhysX on medium or high on my GTX (not the CPU)
  • with the max perfs settings in Nvidia Control Panel
  • with W7 or W8 compatibility,
  • with RyanScenePostProcess,
  • with settings set to low (with a very low resolution),
  • with settings set to ultra (with my native resolution of 1920 x 1080),
  • with Orochi-CEG,
  • with older PhysX drivers,
  • deleting my Documents/My Games/Borderlands 2 folder
    but nothing changed, I’ve still got poor FPS (strangely with no FPS differences between ultra or low).

So i decided to open RivaTuner, and saw my GPU at 20% load and 51°C (yeah, high for that usage, but no fans before 55°C), CPU at 31% load, RAM at 3 / 8 Gb, and only 42 FPS.

Does anybody know where my problem could be?

Thanks.

2 Likes

BL2 is over five years old, and seems to need some attention to get it to play nice on Windows 10 even with a modern gaming rig. First, if you didn’t already, take a look through the posts and links therein here:

There’s a few things in there that might help. Note that there are areas of the game where you will see the frame rate drop regardless, especially if there’s a lot of gear on the ground from enemy/boss drops and lots of visual effects from elemental weapons going off.

Also you didn’t mention this, but are you using Steam overlay or any streaming/video capture software?

1 Like

Yes, I’ve already took an eye to these links.
I’ve read all the posts containing “FPS” on the BL2 Tech Support Forum.

I’ve only tested during the two first hours of the game, but even when I load the game and appear in Southern Shelf (no enemies around, no shots fired so no bullets decals nor a lot of elemental effects everywhere, no gears on the ground…), my FPS drop to 40 - 50 without even moving.

I use the Steam version, with the overlay active (but I don’t open it), and not a single demanding background app (only Speedfan, Afterburner, Logitech Gaming Software…). I’m very regarding concerning my background process.

2 Likes

I’d suggest running it with steam overlay off completely, and see what happens.

@Adabiviak - did you post your specs and settings somewhere? What’s your typical FR in Southern Shelf?

1 Like

Unfortunately, no improvements. :frowning:

1 Like

I have an Asus STRIX GTX970 at 1.1GHz, but with Intel I7 at 4.4GHz and Win 8.1. BL2 runs fine on it. If I turn on VSYNC, it stays at 75 FPS which matches my monitor (1920x1080@75Hz). Without VSYNC, it is over 200FPS and can gunzerk between 100 and 150 FPS with BL2 FRAMERATE set to unlimited. I also have PhysX Effects set to low so that loot doesn’t fall through the floor.

Your hardware should be capable, so concentrate on the software.

You don’t mention the NVIDIA drivers that are installed. The 397.31 drivers are a disaster. I havn’t tried the latest 397.55 HOTFIX that came out Thursday. I’m running 391.35. You could try installing GeForce Experience and see what it recommends for optimal settings.

3 Likes

You make me so envious. :drooling_face:
Actually, I use the 397.31. These are the last ones I saw on Nvidia’s website, and I updated a few hours ago, from a one month old driver (I didn’t see the 397.55, maybe a few days before seeing this one on the french website?). I’ll try yours, and give you a feedback once installed and tested. I didn’t know that new drivers could f*ck up a 5 years old game’s optimisation, everything else runs smooth.

1 Like

This is noteworthy - I didn’t know that , but it makes complete sense ( I also have mine on low - but that’s for my eyes’ sake ).

@Kurtdawg13 : FYI ^

2 Likes

In the list of things that the HOTFIX is supposed to fix that 397.31 broke:

Windows 10: Driver may get removed after PC has been left idle for an extended period of time.

I had 397.31 for a few days, and besides freezes, my WIn8.1 would sometimes say that the driver was no longer installed. Used DDU to delete 397.31 in safemode and went back to 391.35 because the forum comments on guru3d.com seemed to agree that was a solid version.

2 Likes

Maybe that should be “less loot falls through the floor”.

When I had PHYSX EFFECTS set to High, after killing Bunker, some loot would end up on the level outside the door to Control Core Angel with other loot on who knows what level. I decided that loosing a Sham wasn’t worth the eye candy.

2 Likes

My specs:

  • MB : Asus Sabertooth X99
  • CPU : Intel i7 (5280k) @ 3.3 GHz
  • Cooler : Corsair Hydro Series H80i GT
  • RAM : 32 GB Corsair Vengeance DDR4 2666
  • HDD : Intel PCIe NVMe 3.0 SSD
  • PSU : Corsair RMx 750W

My FPS there will range from 164 (capped by G-Sync) to maybe as low as the mid 50s if I throw a lot of debris in the middle of a long draw.

On Topic - (and I hate answers like these myself, usually because everything else works fine with them); have you tried running the game without Speedfan, Afterburner, or Logitech bits?

Alternately (and this is almost a knee-jerk response from me): do you have Fast Boot enabled? I did, and it was causing slowdowns like this (something about trying to suspend the video system not working right). In my case, a warm restart would work every time if you want to try that for a quick check.

2 Likes

If you want the HOTFIX (I don’t think it is WHQL and I don’t want to be a guinea pig):

http://nvidia.custhelp.com/app/answers/detail/a_id/4661

1 Like

More than an hour needed to do a clean install of a previous version of Nvidia driver, and nothing changed. If I run the game with PhysX on low or medium, I’ve got the same FPS as before. If I set it to max, the game freezes, and I only can quit it thanks to the task manager.

1 Like

I didn’t try without these three ones, because I couldn’t enjoy a game without them (a good overclock with AB, a great silence with SF, and a pleasing g502 full of programmable buttons with LGS).
Also, yes, I have the fast boot enabled.
I’ll try all your suggestions tomorrow.

1 Like

I also have Logitech Gaming Software 8.88.30 installed. It might not be current, but my G610 is working OK.

I’m not using Fast Boot, but I am running Win 8.1 and BL2 on an SSD.

It probably won’t help, but have you tried "VERIFY INTEGRITY OF GAME FILES…” for BL2? Details here: How to verify Steam Borderlands 2 game files.

1 Like

How old is your computer? because that’s about a 6 year old setup. Don’t know if it still does this but windows likes to force you to use their generic driver even when yours is installed. got a guide somewhere. New drivers will absolutely ■■■■ with older games, if they remove or break a dependency. Ever tried playing an early 2000’s game on win10? Like zootycoon? It’s damn near impossible.
I recommend ditching windows and installing linux. Or dualbooting.

1 Like

I’d swap from Windows to Linux in a hot minute if I thought Linux would run my old games. What old games are you running on Linux?

1 Like

The 397.55 driver didn’t solve my problem. The fast boot neither.
When I do “verify integrity of game files”, it downloads a 9.4 MB package, everytime. It’s very strange.
My computer is 4 years old, but I don’t have the budget to upgrade it every two years.
I personnaly never had any problems with W10 generic drivers. The older game I’ve played since I went on W10 was Half Life 2 and It was running smooth. With BL2, this is the first time I’ve got a problem (I must precise that with my old rig, I only play 5+ years old games)
For Linux, I’m sorry, I’m pretty sure it may solve my problem, just like a W10 fresh install, but for more FPS in BL2 only, I won’t have the courage to tryit.

2 Likes

There is a possibility that your AV software is preventing that update file from being saved. Both Windows Defender or BitDefender have caused issues recently. Whatever AV you have, check that it isn’t locking your Games folder and sub-folders. You should be able to add an exemption to the whole directory tree starting with your Games folder.

1 Like

With Win8.1 I always get the “1 file failed to validate and will be reaquired” each time I validate. It downloads a 9.4 MB file every time. It doesn’t seem to change my settings, so I think it can be safely ignored.

1 Like