Missing shock element on Amara (PS4)

Is anyone else missing the shock element completely from Amara?

What I’ve tried:

  • Backed out to title screen
  • reset game
  • reset console (figures why not)
  • respec of her skill points
  • swapping between elements and removing it

No luck at all. This what it looks like when I removed corrosive element (to get the default shock). image

(Xbox) Probably the same issue but since the Takedown the icon was just blank, switched to another element and took it away and the shockra icon was back again.

Although I didn’t paid attention if it is actually doing shock damage…
The last patch already broke all the COM icons for skill bonusses, go figure… :roll_eyes:

It really sucks lol. Mine won’t switch to shock at all, so I don’t even have the icon giving me hope.

I spent hours farming a corrosive monarch and right when I switched her element I could never get it back smh.

I wanted to do the guardian takedown before they nerf it next week

On pc if you have the driver equipped, don’t worry as you will still deal shock damage. You can see the shock element being procced on you. Maybe it’s just a visual bug. Hopefully it’s the same case on consoles

It’s shock, just the colors in trees tab are changed, and the Shockra icon looks like this.

It’s actually worse than that. It doesn’t register any element but treats it as an empty slot so I can’t even use my action skill if I don’t have corrosive or incendiary selected

Hmm, will check tomorrow.

Even though you don’t see it, you still get shock as your element. You can test with infusion or forceful expression on the dummy for easy proof. With “blank” in the element slot, you shoot the dummy, you get the weapon damage plus shock damage.