Mission: Legend of MCSmugger bugged. Cannot complete

Hello,
First post on the forum:
In the new DLC, my mission: Legend of MCSmugger is bugged. I have picked up the three baddass hearts and my mission shows I have to “Climb Mount Maraboshi”. I reached the top (with the graveyard where I have to do something with the three hearts, but “Climb Mount Maraboshi” stays unchecked. Nothing happens. I have reloaded and restarted the game several times, even did a few other missions first, but it is still bugged.

2 Likes

Can you put the hearts into coffins?

Hi,
No I cannot.
The mission says I have to climb mount maraboshi.

1 Like

Having a similar problem getting the main story line to progress on the road to ruin mission.

Same for me, playing on ps4. I am at the top of mount maraboshi and can not complete the mission. Granted, i just started the dlc so i have not done the story mission for ashfall peaks yet, but that never stopped me from doing side content before. I gathered all the hearts, killed everything, reloaded twice, climbed back down the mountain amd back to the top… still nothing. Level 60 amara on m10

Did you take the detour to look at a chest along the way? That shoudn’t make a difference, but you never know.

1 Like

Hi,
Yes I took the detour , but still happening. Tried changing mayhem level from 10 to another, progressed main story a bit further, but still having the issue, even went in air with iron bear, support says I have to clear cache (but PS4 does not have) or try to delete the game and reinstall but that sounds like a big solution which not even work.

That’s the standard fix attempt for pretty much anything. I think PS4 would be similar to XB1 in that it requires a full shut down…

Yeah, found this:

Don’t know if it will fix the issue. Usually, progression issues like this are caused by doing something slightly out of sequence that trips up the script triggers. If the reset doesn’t fix it, your best bet is to join the game of someone else running the same side quest.

Yes i did, killed everything there then jumped over the launch pad and looted the chest. Found 2 m10 legendaries in that one.

Will try this tonight and let you know. Thank you

Tried the shut down and unplug, that mission is still stuck. So far it is the only one though.

Is there any update on this issue and is it being looked into? I am also experiencing this bugged mission and it it stopping me from progressing.

Hi,
I contacted support, they gave possible solutions to try:

  • Clear cache (but cannot do on PS4)
  • Network related, reboot network and such (I’m not buying that)
  • Reinstall the game (did not do since I find it rigorous to do)
  • Play with a friend online/local who has not started the mission (I don’t have PS plus and only one controller, so no option either).

So I guess I will finish the DLC, and reset missions afterwards to start again and leave the mission unfinished for now. Resetting missions was my plan all along some day.

Same bug with lvl60M10 Amara. Before that it went fine with lvl60M10 Zane(twice) and lvl60M10 Moze. PC/Steam

P.S. Luckily i have backup save from yesterday. Everything went fine for Amara from there (without mayhem). Maybe it was bugged in the first time because i change mayhem modifiers in the middle of quest and died by falling off the cliff. Anyway, i tried to load bugged save after that (as well as using ccleaner an other soft to clean temporary files) - didn’t help.
I guess i will go back to backup-save.

I’m having an issue getting past the locked door, too. I’m on PC.

as of April 2021, this bug still occurs. why at this point in the game’s life cycle has this bug that happens in so many missions in this DLC still occuring? it’s been almost a year since the DLC released

Now May 2021, playing on PS4 pro - this still this issue persists!
I exited to the main menu before finishing the side mission and when loading back into the game it now doesn’t recognize that I have the the badass hearts in my inventory when it reach the summit, as the audio does not play, therefore place heart in coffins to open the door. I have tried all fixes above (except reinstalling the game) to no avail. Badass Devils don’t re-spawn either…