Mods won't start up

you could try to copy the big file of the mod in your data folder along the big files of hwrm, and add -mod nameofthemod to the shorcut.
But I don’t see how it would resolve the issues you have

Ohh, okay.

So i guess im ■■■■■■!

There’s something weird happening with some Steam clients, it seems. I’ve got, for the past few days, several reports of my mod not working and crashing like instantly. So, as usual, I checked on my own side, starting the mod with the Steam Launcher so I would be in a similar situation as the player, and it worked like a charm.

Got the error log of the guy after getting in touch with him via Steam, and for some weird reason, files like \soundscripts\SoundConfig.lua that were apparently garbled beyong recognition and making the game CTD at launch. So, I forwarded him the contents of the .lua file, walked him into doing an overridebigfile, and then, new CTD to another file, also turned into nonsense, apparently. Then, I did it again, and when he got a third file messed up, I just realized that this file was NOT modified by my mod. He was having a CTD caused by a scrambled file from the Vanilla game, but he could still launch the vanilla game itself without issue.

I linked him to a manual download of the .big file through ModDB, which is literally an upload of the .big Steam sent me, and then, the game works, no problem whatsoever. But there’s, for some reason, some weird corruption problem in a few users who DL mods (and, yes, I asked, the guy’s computer was not using some strange configuration or comma replacement by point or whatever).

Has anyone else encountered that issue with their players?

1 Like

Really strange indeed ! oO

Could it be that some files had been crypted by a malware or someting of the sort ? Just an idea I’m throwing out like this, 'cause I’ve clearly no idea of what could be causing this sort of problem !

Perhaps calling the devs for help ? @Bitvenom ?

1 Like

OK, I just had another player who reported the very same bug with the sound.lua file being corrupted. Here is the log file he posted:

Tue Jan 12 06:57:01 2016 Version 1.30, Build Number 21, Changelist Number 1089620 Loaded Archive: 'Homeworld2.big' Loaded Archive: 'UpdateHomeworld2.big' Loaded Archive: 'HW1Ships.big' Loaded Archive: 'UpdateHW1Ships.big' Loaded Archive: 'HW2Ships.big' Loaded Archive: 'UpdateHW2Ships.big' Loaded Archive: 'HWBackgrounds.big' Loaded Archive: 'UpdateHWBackgrounds.big' UTIL -- filepath failure, path doesn't exists 'C:\Program Files (x86)\Steam\steamapps\common\Homeworld\HomeworldRM\data\locale\English' Loaded Archive: 'English.big' Loaded Archive: 'UpdateEnglish.big' Loaded Archive: 'Compatibility.big' Failed to Load Archive 'C:\PROGRAM FILES (X86)\STEAM\STEAMAPPS\COMMON\HOMEWORLD\HOMEWORLDRM\DATA\HWArgon.big' Loaded Archive: '76561197972748679\403171608\WC4FC_Remastered.big' Failed to Load Archive '..\..\DATAWORKSHOPMODS\76561197972748679\403171608\English.big' Uing ..profiles\ for profiles folder GAME -- Using player profile Dileesh FryStank Changing from a 32 bit colour depth in winNT (6.2 build 9200), Display: (0, 0, 1920, 1080) - (0, 0) Display: (0, 0, 1920, 1080) - (0, 0) Switching to a 1920x1080 32bit mode GL Info: 3.3 - 3.3.0 NVIDIA 359.00 GL Vendor: NVIDIA Corporation GL Renderer: GeForce GTX 760/PCIe/SSE2 GL Part ID: 760 GL Part EX: /PCIe/SSE2 Loaded Archive: 'EnglishSpeech.big' Loaded Archive: 'UpdateEnglishSpeech.big' Loaded Archive: 'Music.big' Loaded Archive: 'UpdateMusic.big' LUA 'Data:Sound/root.lua' -- parameter: <statement> expected; last token read: `˜' at line 1 in string "" Unable to set sound root path, missing root.lua in Data:Sound -- FATAL EXIT -- soundmaninit/712:! --stack trace-- Restoring video mode Display: (0, 0, 100, 100) - (8, 31) Display: (0, 0, 100, 100) - (8, 31)
As you can see, the file root.lua is being corrupted in the Steam version of the mod he had. However, it works fine on my end and for the previous user, the only fix was, as I said, to get the ModDB version (which is a RAR file containing the .big file I got from Steam).

As for reference, here is the root.lua file directly from the mod folder in the Workshop Tool:

[code]-- LuaDC version 0.9.19
– 5/23/2004 7:24:49 PM
– LuaDC by Age2uN
– on error send source file (compiled lua) and this outputfile to Age2uN@gmx.net

version = 3
priority = 99
compression = 0
volume = 1
volumeRand = -1
frequency = -1
frequencyRand = 0
destination = 1
patch = 1
numChannels = 1
maxPolyphony = 1
loopStart = 0
loopEnd = -1
startOffset = 0
loopCount = 1
loopCountRand = -1
type3D = 0
doppler = 0
coneMin = 0
coneMax = 0
envelope =
{
{
distance = 0,
volume = 1,
reverb = 0,
duration = 0,
equalizer =
{ 1, 1, 1, 1, 1, 1, 1, 1, }, },
{
distance = 500,
volume = 0.9,
reverb = 0,
duration = 0,
equalizer =
{ 1, 1, 1, 1, 1, 1, 1, 1, }, },
{
distance = 1000,
volume = 0.6,
reverb = 0,
duration = 0,
equalizer =
{ 1, 1, 1, 1, 1, 1, 1, 1, }, },
{
distance = 2000,
volume = 0.25,
reverb = 0,
duration = 0,
equalizer =
{ 1, 1, 1, 1, 1, 1, 1, 1, }, },
{
distance = 4000,
volume = 0,
reverb = 0,
duration = 0,
equalizer =
{ 1, 1, 1, 1, 1, 1, 1, 1, }, },
}
randSampContainer = 0[/code]

I encounter this all the time, is very frustrating finding that a user that had no problem at all with the mod, can’t even load the mod in the next update.

OK, the guys at Phoenix Interactive gave me the fix for this:

Copy of the post made by [Phoenix]Teal’c from Phoenix Interactive, found here: http://steamcommunity.com/workshop/filedetails/discussion/565216687/492379439679351160/#c492379439683535026

This should fix any crash to desktop that happens because of this specific bug.

This error is typically generated by steam. (or GBX Tools …) When create .big, the tool corrupts this file during downloading … we can’t resolve it, actually the only solution is to redownload this. But before this, don’t forget the delete of mod in HWRM folder is NOT sufficient.

Step 1 : Stop subscribing to mod ;
Step 2 : Stop steam process, close steam, same.
Step 3 : Go into your Steam Folder, (Same of HW, not the steam main folder
if steam is not installed at the exact location of HWRM). :
…\Steam[Library]\SteamApps\workshop\content\XXXX\403171608[XXXX is number, but random, and contains the next folder, number of this mods is general and not random]
Step 4 : Delete NUMBER OF THE MOD folders (contain save of mods if you delete in the HWRM folder, steam automatically takes these files.)
Step 5 : Go to /Homeworld/HomeworldRM/DATAWORKSHOPMODS/76XXXXXXXX/NUMBER OF THE MOD
Delete this 403171608 folder. [76XXXXXXXX is your number of steam user or HWRM profile. Contains all mods of HWRM that you subscribe in Workshop for [RM].
Step 6 : Subscribe to this mod. And re-download all of file. You can re-install patch if you wan’t, but this patch doesn’t have any link
with this download, you can just download the workshop mod.

Step 7 : If you are lucky, the error with : last token read: ’ ’ at line 1 in string “”
Don’t appeared at the same location, or don’t appear at all.

Optional
Step 8 (by Rufus): sacrifice a goat over your computer. Cleaning the mess should keep you busy long enough for me to write a new update and cause another DL that will probably fix the mod.

1 Like

So steam has a second copy of every mod in my PC?
I never knew that, and that explains why my previous attempts of fix, never worked for me.

Bingo. Annoying, ain’t it?

1 Like