Moze's Jump not high enough?

Is mozes jump the same high as the others? I try like an hour the jump to the radio station in lectra town. It feels like the jump is a bit shorter then the others. Someone with the same problem?


yes,i’m at lectra town and there is a point i can’t jump to with moze,to reach a crimson radio!


I think I know what you’re talking about, but you’re meant to jump on the light and then go to the building. Not jump across from building to building. I haven’t played as Moze so I can’t tell you if that’s true but I already got that radio tower so I know how it’s possible.

1 Like

Tried and failed many times from the light for the radio, and now in Skywell27-shuttle. It’s like she reaches for the ledge but can’t pull herself up. Wasted $20k trying to get to the ledge

@Rumor has it correct. Jump from the roof of the building across the road to the curved light stand, take a running jump off that to the yellow paint, and done.

Just finished completing the whole map and all challenges. There are some spots where if you go the wrong way you will not make it, but there is always a different route. My biggest problem was thinking I needed to get across to something right down at the bottom, but it was actually just off-map scenery; I died.

1 Like

Can it be that you can’t reach the radio with 30 fps? I switched on 60 fps today and got it instand

I’m on 30 fps (XB1) and not had an issue making any jumps so far. Admittedly, the timing is kind of critical for some and I’ve been around more than once before getting it right (there’s a spot in the Meridian Outskirts were positioning is absolutely critical) so a higher fr might help for that.

I haven’t had an issue personally. Made the jump from the light to the building on first try. I’m also running at 120 fps on PC, so that may help. I had to sprint before I made the leap.

Huh… I don’t know what is going on. I jump from the light (always have been) and Moze reaches for the ledge then falls down to the window directly below the yellow paint. From there I try jumping up to the edge again but that doesn’t work either. I’m on Xbox one X and tried changing the settings but no go.

Are you hitting the jump button again as you reach the ledge to mantle up?

Take a running jump from the ‘back’ of the light - gives you more distance. And as @klg_chaos said hit the button to mantle on the other side. (That’s why there’s yellow paint on the edge.)

Wow, thank you! I was being stupid and thought it would auto complete the jump like in D2. If you couldn’t tell, I’m a BL noob.

Wherever you see yellow paint splashed on something, you will need to mantle.

For anybody still having problems with this, I found another way. I tried several times with Moze but couldn’t quite make it from the light, but if you unequip your grenade mod, you can grenade jump from the window below the ledge and mantle up to the roof.

1 Like

Do you have the Rushin’ Offensive? Maytbe this ability is effecting our run speed?

I 100% the game as moze, I can assure you she can reach everything at least on Xbox.

There’s an option to enable auto-mantling if you hold forward.

I have the same problem with Fl4k, I recorded video of it as well. Fl4k refuses to mantle once reaching the vent on the building. Turning on auto-mantle solved this. Just don’t forget to turn it off or you’ll end up auto-mantling yourself into the toxic water!

Hello. I am having the same issue playing with Moze. What do you mean by switching to 60fps?

I am playing on Stadia, & I’m having the same issue of not being able to make long jumps. I’ve had to abort a couple of missions because of it. What am I doing wrong?