Multiplayer Incompatible Games [-mod command arguments non compatible?]

This seems to be happening a lot to me, sadly I stopped playing HW:R multiplayer due to this and it appears no one had this problem nor has an answer to it. This is the problem:

When joining a multiplayer game, it marks it as “incompatible,” joining it gives me a notice saying something along the lines of “You are running -mod command line arguments that are non-compatible” at least that’s how I remember it.

When clicking “More Info” it shows all needed files and possible mods etc. I have every single file needed on my side and on the hosts side. The game isn’t password protected and the only thing I have ever really done is test the beta update, (which I removed on the same day due to it not helping).

What I have tried so far:

  • Steam Restart
  • BETA update (before the release)
  • Checking files (which was hard cause it’s not very organised
  • Removing the official balance mod (no other mod was removed)
  • Verifying files
  • Re-installing

I’d really like some help, it’s been a big issue on my end.

Problem was resolved

how?

I bet it was a preview patch.

Surprisingly, multi just stopped working on a Mac OS, I had to launch it on a bootup of Windows Vista and after that multi started to work.

My only guess is that something permanently messed up the codes on the Mac version.

I’ve actually tried installing and uninstalling the patch, didn’t help with the issue