Mysterious fatal exit

I’ve been giving the remastered version of HW@ some test spins, and I run into a fatal crash occasionally. I haven’t noticed an ingame event that causes it, and I’ve played entire matches to completion. The message I get is

Ship HWAT_UNH_NCHarvester has no Collision family. Fix this by setting the collision family in Shiptuning.xls
– FATAL EXIT –
collision/634:!
–stack trace–
Display: (0, 0, 100, 100) - (8, 31)
Display: (0, 0, 100, 100) - (8, 31)

Naturally, I went to go check up on HWAT_UNH_NCHarvester.ship…

NewShipType.CollisionFamily=“Small”;

and small is still in my familylist.lua, so I’m at a bit of a loss as to what’s going on. That’s my resource collector, so is it possible there’s some issue with our custom asteroids I should look for? The fact that I’ve finished entire games without it happening suggests it’s something fairly esoteric…

If any gearbox folks want to take a look, I have a private build that produces this error at http://steamcommunity.com/sharedfiles/filedetails/?id=448719506

I ran into this a little while ago actually

Long story short, there’s probably no collision family on your 'roids :smile:

Derp, I should have searched harder. Thanks for the pointer!

aaactually nope. That didn’t fix it. Now I’m just getting the same error but complaining about the asteroids instead of the harvesters.

Disregard that, I did a stupid in the copy/paste, seems to be fixed now.

2 Likes