Need some help borderlands 2

So I still have my PS3 and got borderlands 2 with the DLC since I had never finished it. Playing Axton, loving it even got the space knight head to drop from bunker. got thru regular game and almost thru TVHM doing the toil and trouble quest. Then all of a sudden I cannot access Eridium blight to get to the Arid Nexus… My goal was to bum rush through the first two play throughs and then soak in borderlands 2 main and side missions and all the DLC in all its glory. Ive tried several things to fix this issue but nothing works and have determined that the game is corrupted in some form or another. I would hate to start over… Im devastated this happened, and yes I should have had a back up save file. Ive tried rebuilding the database, system filechecker… Loading different games and trying different methods but no matter what I cannot access Eridium Blight any longer. I feel that im pretty much screwed at this point and will have to start over but is there anything I can do to really speed thru things ive already put in alot of time and I just want to hurry up and get thru TVHM so I can enjoy the really Real game. Profile name is EntomberExarch on PS3 anything anyone can do would be greatly appreciated

You mean through the fast travel? IIRC you need to enter through the Dust on each subsequent playthrough. Kinda like getting to the fridge via Three Horns Valley after Rising Action during bright lights flying city. If you mean the exit from the Dust is inactive I got nothing but confusion.

Ive tried that as well and the game freezes, everytime it does i can still access the playstation menu and just quit the game but I cant get to eridium blight either through fast travel or the direct path through the dust

Have you tried the Gearbox Support folks first? Hate to see you waste all that time if they can help you out…

I actually never considered it. Is there a direct number I can find or I suppose just email them?

Is this an older disc that you have had or purchased preowned? Does it have a scratch? Or if you downloaded it from PSN was there an interruption that may have corrupted the data? Maybe redownloading the game could help?

The disc is in great condition, its the GOTY version and I did make a ticket for gearbox as well.

Check further down in this forum as I believe there is a PS tech support section there.

Ok, im pretty sure if they cant help me then im SOL. Thanks for the help guys have a good one

Just so you know, whenever I’ve seen folks having problems with an area crashing the game as soon as they try to travel to it, it’s almost always one of:

  • corruption of part of the game files even if the disk looks to be physically fine. Not a PS3 owner, but on 360 you could install a game from physical media to your internal hard disk, which sometimes fixed otherwise game-breaking media corruption issues
  • a corrupted cache file (don’t know how PS3 works in that regard, but 360 has an option to clear you system cache which fixes a lot of glitches)
  • first signs of problems with your console physical hardware

Note that I doubt that it’s your game save data - much more likely to be the game choking on a read error trying to load the map resources.

1 Like

If thats the casr will 2K support be able to do much? Ive never had to contact before with an issue like thisnand ive always been skeptical as to how much they can actually do to help with an issue such as this. Ive already tried clearing the cache etc. Maybe downloading the game to the hard drive from the store? may help?

I’d see if you can install from disk first. (I’m assuming downloading from store means buying a digital copy). Or, you could see if you could find another physical copy of the GOTY version you already have (even if that’s just borrowing one from a friend.)

1 Like

I believe any copy of Borderlands would work GOTY uses two disks one to download dlc from and the other for just the game. So if it is a problem with your disk you only need to reaquire the base game.

2 Likes