Network Error: You must connect to the online service to play online

Network Error: You must connect to the online service to play online.

I get this error whenever I try to play online with my friend on Borderlands 3. I’ve been searching for solutions, verifying game caches, checking if BL2 works, reinstalling, restarting, and port forwarding for hours but to no avail. I’ve opened 3 support tickets but I haven’t gotten a single response back yet. I’m using the Epic Games Launcher; other games work online from the same launcher.

Does anyone know why this happens?


9 Likes

You are not alone. Same here. Its really strange. It looks like the game doesnt even try to go online. It instantly says “Nope. No connection”

4 Likes

same +1

1 Like

I had this issue yesterday and it went away on it’s own after re-launching the game many times.

The last launch where it started working was when I exited the Epic Launcher and launched the game directly from the folder (C:\Games\Epic Games\Borderlands3\OakGame\Binaries\Win64\Borderlands3.exe on this system).

Exiting the launcher may be what solved it however it could also have been that they just enabled the service in my region at that time (Sept 13 14:00 UTC)

[Edit] See matthieuka’s post below about unblocking lsass.exe .

Same, I have yet to be online…
Either “Signing in < epic-name >” -screen fails for some reason or the problem is before that.

I tried it.Does not work for me. To bad.

1 Like

I have the same problem and gearbox161’s solution doesn’t work for me :confused:

1 Like

Dont do it. You will kill your savefiles. But you can delete any folder except the savefile folder in there.
And no, it does not work :wink:

I’m having the same issue. Can’t play online with any of my friends.

If you just want to play with your friend try this.
https://www.vpn.net/
Hamachi will simulate a LAN over the internet. BL3 supports LAN. Both of you need to install it. Its free and quite easy to use.

Edit: After i turned off my router/modem the game instantly told me i have no connection. I turned it back on and the “no internet” on the screen vanished but as always i cant use the online parts of the game

I have the same here. Please let me know what you need Gearbox to resolve this.

Started to work here for the very first time. Maybe it needed a Monday.

I ticketed 2K support before this, but not sure if that helped : )

1 Like

Who knows. Maybe its like in the Battleborn Alpha and they have to unlock each player personally again.

I tested it with a simulated LAN tool. Even that does not work

I had the same problem. And to resolve it, i unblocked “lsass.exe” in my firewall.
or maybe it’s just a coincidence, idk
hope this helps

2 Likes

I dont even have that file. Is it in the windows\system32 folder?
I have a fresh installed win 10 on my pc

EDIT: Wait. That is an L not an I. ok found it

Holy ■■■■!!! That worked. The strange part is, my firefall said nothing about it. You are my hero.
I just tried it to give the file an exception. Wanted to be sure.

1 Like

i had the same problem then i tried to flushdns

  1. lush your DNS Cache.
  • Here’s how:
    • On your keyboard, press the Windows key + R.
    • Type “cmd” and press enter to open the Command Prompt.
    • Type without quotation marks “ipconfig /flushdns”
      worked for me

Glad it worked for you, but that file allows for changing security settings on the computer. I doubt Gearbox wants to have access to that through the firewall. In any event, I was unable to get it work for me.

I’ve also tried flushing dns several times.

I’m going to change my dns settings. See if this helps

Gearbox > 2k Games > Epic > Tencent > Loves information :stuck_out_tongue:

1 Like