New Forum Features Thread

It is what nightmares are made of.

2 Likes

A post was merged into an existing topic: New Forum Feedback Thread

Is there a way to disable the Ctrl+F search command intercept? Using Opera browser.

Hit it twice. Yeah, that sucks, but better than nothing.

Hey @JoeKGBX or @MereAtGBX:

Noticed that the discourse user preferences page has undergone some changes, which is great. But the user badge no longer shows on your user card, even if one is showing as selected in your Profile settings. Can you ask about that please? Ta!

Edit: Aaaaaand… as soon as I post that, the badge mysteriously reappears. I’m assuming that opening the Preferences after the change momentarily clears the badge, and it takes a while to reappear? Odd, but it’s back so, :thumbsup:

1 Like

Hey, I just tried to edit one of my old posts and all the color and underscore formatting won’t show up anymore :frowning:

Bug or feature ?

They redid the HTML formatting on the forums about a month ago. So editing an old post will cause the old formatting to no longer work. You need to do things like change the…

  • COLOR to a lowercase color
  • Instead of [U] you need to use lowercase [u]
  • Instead of ## you need to put a single - under the line you want bolded.
  • Etc…
1 Like

Thanks :slight_smile:

I guess I have a lot of work to do now…

edit:

That still works, but it requires a space between the ## and the text

1 Like

They did that so hashtags in posts would display as #hastags. Same thing with headings - put a space between the last # to indicate heading level and the heading text

Level one is # Level one

Level two is ## Level two

Level three is ### Level three

and so on…

2 Likes

Is anyone else getting odd stuff happening with the placement of buttons and text within buttons? Here’s what I’m seeing (FireFox 48.0.2, 100% page rendering) for the buttons below the post count slider:

27 AM

and below the last post in a thread:

22 AM

The last example, it looks like icon and text for the “Pinned” and “Tracking” are both centred, which results in the text being pushed out of the bottom of the button box, so that’s got to be a CSS issue.

The first one, really not sure what’s up with the placement? They used to be side-by-side.

(@MereAtGBX, @discourse)

Edit to add: It only does this on my desktop running an older version of FF. Everything looks fine on my laptop which is running Firefox 56.0. It doesn’t appear to be a script issue as far as I know?

I’ll check this out, @VaultHunter101!

I’m not seeing anything out of the ordinary in Google Chrome, is anyone else seeing this? And if so, in which browser?

I only skimmed over what you wrote, but have you tried clearing your cache? 9/10 that is the cause with websites not rendering properly.

@MereAtGBX @discourse: A feature request for consideration, please!

There are recurring requests that user signatures be allowed as they were on the old vBulletin system.

I can understand why full-blown signatures could be problematic so, as an alternative, how about one extra line of user-definable text that would appear in the header of each post, directly below the forum name/name/title line? This would mean that the post header was the same height as the user avatar, which isn’t a significant difference and would allow for more informative user post headers. If a user background image could also be added to header (between the avatar and the “in reply to” area), that would be additionally super awesome!

2 Likes

No plans for this, however, there is an “opt-in” signatures plugin that can
be run on enterprise instances.

I strongly recommend not going this route, but at least then the pain is
only shared by those that have ticked the “I want pain” button in their
user profiles.

Out of curiosity, what would that practically look like? I’m assuming it’s an extra area that appears at the bottom of each post, but does it have a fixed size and how big is it? I can see anything more than a couple of text lines being a pain in terms of making the threads take even longer to load/scroll - bad enough on desktop but I imagine very painful on mobile!

Hey @discourse, if you don’t mind I’m having issues trying to format something. I did my best to look on the Discourse forums and on html forums via Google searches, but I can’t seem to figure out how to put a summary/hide details in a html table. Hopefully it’s possible.

Thanks in advance for your time, and sorry if this wasn’t the place to ask this.

Running into a script bug today while trying to edit an existing post. The site script keeps hanging. When I hit the “Debug” option, the Firefox console shows this line:

    css: function( elem, name, extra, styles ) {
        var val, num, hooks,
            origName = jQuery.camelCase( name );

Just going to try this in a different browser…

Edit: Works in latest Firefox without issue, but 48.0.2 seems a little iffy. Not sure what’s going on here.

Edit2: Seem to have been having major latency problems earlier today over some, but not all, connections. That may have been the issue?

Edit3: Nope, same issue on a long post with lots of formatting, but this plain simple one seems to load and edit just fine.

@discourse: liking the new Insert date function, which is really slick, but there’s a slight bug if you use the LLL\T\Z option

May 21, 2018 5:30 AMAmerica: Los Angeles, May 21, 2018 1:30 PMEurope: London

Needs a space between the AM and the user time zone!

1 Like

The new forum absolutely kicks @$$, great job guys

Hey @VaultHunter101, I didn’t know where else to ask this and thought it better here than a PM.

I’ve been trying to figure out how to indent text and haven’t been able to find the code. Then I found something wierd : one of my own threads had indented text :man_facepalming:.
I went into it and found I had used this :

                  

          which results in this.

Is this info actually in the forum somewhere?

1 Like